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Creating components in Macromedia Flash MX

Components are Macromedia Flash MX movie clips with defined parameters that are set during document authoring. Parameters 
correspond to variables in the ActionScript attached to the movie clip, which control the behavior and appearance of the movie clip. In this 
tutorial you'll learn to create:

A button component with parameters for a customizable button label, label font, and label color

A custom icon for the component to appear in the Components panel when you add the component to the Macromedia Flash MX 
application

A plain text or XML description of the component that will appear in the Reference panel

A Live Preview movie that enables users to see the effects of different parameter settings while working in the Macromedia Flash 
MX authoring environment

A custom interface for the component, to make it easier for users to enter parameter values

For best results in completing this tutorial, you should be familiar with the Macromedia Flash MX UI components, including how to add a 
component to a movie and set its parameters. For more information, see Macromedia Flash MX Help > Using Flash > Using Components 
and Flash MX Help > Using Flash > Introduction to Components Tutorial. In addition, you should be familiar with variables in ActionScript, 
including variable names, values, and types. For more information on variables, see Macromedia Flash MX Help > Using Flash > 
Understanding the ActionScript Language.

Components provide prebuilt user interfaces and scripting for adding interactivity to Macromedia Flash MX movies. With components, you 
can add interactivity to a Macromedia Flash MX movie without needing to create the ActionScript that controls the interactivity. To use a 
component in a movie, you simply add an instance of the component symbol to the movie and select values for the component 
parameters.

Note: Components replace and extend the SmartClip movie clips introduced in earlier versions of Macromedia Flash. You can save 
components authored in Macromedia Flash MX in Macromedia Flash 5 format. However, some component features are not supported in 
Macromedia Flash 5. Information on features not supported in Macromedia Flash 5 appears in notes throughout this tutorial.

You can use components to create simple interactivity that affects only the current movie, such as buttons that navigate between frames 
in the movie. You can also use components to send data to an application server and receive data from a server—for example, in a web 
form that collects user input on a commerce site.

In this tutorial, you'll learn how to make a labeled button component. 

This sample file requires the latest version of the 
Macromedia Flash Player.

Download it now. 

We've provided a button for you to use in creating the labeled button component. The button pulsates in the Up and Over states.

Note: The button's pulsating behavior cannot be previewed in the Macromedia Flash MX authoring environment until you create a Live 
Preview movie for the component document file. To preview the pulsating behavior without a Live Preview movie, choose Control > Test 
Movie when the sample FLA file is open in Macromedia Flash MX.

Download the Windows creating_comps source files (28K)

Download the Macintosh creating_comps source files (28K)
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When the file decompresses, a folder named creating_comps is created on your system.

If you have trouble downloading or decompressing the files, see TechNote 13686.

Workflow for creating components 
Create the component movie clip 
Add ActionScript to the component 
Define the parameters 
Create a custom icon 
Add a description 
Create a Live Preview movie 
Set the path to the Live Preview movie 
Create a custom interface for a component 
Set the path to the custom interface movie 
Use the component in Macromedia Flash documents 
Create your own components 
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Workflow for creating components

To create a component, you begin by creating a movie clip that will serve as the basis for the component, and then add ActionScript with the 
variables that correspond to the component parameters. Next, you define the parameters for the component in the Component Definition dialog 
box. For each parameter, enter a name, variable, value, and type.

The parameter name helps users understand the purpose of the parameter. The name does not need to conform to variable naming 
conventions. For example, we used the name Label Font for a parameter that specifies the font used in the button label.

The parameter variable is the variable name used in executing ActionScript commands attached to the component movie clip. The entry in 
the Variable field must conform to identifier naming conventions. The first character must be a letter, underscore (_), or dollar sign ($). 
Each subsequent character must be a letter, number, underscore, or dollar sign. For example, we used the variable name labelFont for the 
button label font.

Note: If you want, you can enter the parameter variable name in the Name field, and leave the Variable field blank. Macromedia Flash MX 
then uses the entry in the Name field to execute ActionScript commands.

The parameter value is the value assigned to the parameter variable when the variable is called in ActionScript commands. The value you 
enter in the Component Definition dialog box is the default value for the parameter. The component uses this value until a user enters a 
new value for the parameter. For the default value for the button label font in our sample, we chose Arial.

The parameter type identifies the data type, or the kind of information, that the parameter variable can hold. Parameters can be of type 
Array, Object, List, String, Number, Boolean, Font Name, Color, or Default. For Default type, Macromedia Flash MX interprets the type 
based on the value entered. True and false values are interpreted as Boolean type. Numeric values are interpreted as type Number. All 
other values are interpreted as type String. For more information on data types, see Macromedia Flash MX Help > Using Flash > 
Understanding the ActionScript Language > About data types. The parameter type for the button label font in our sample was Font Name.

The following procedures are optional in creating a component:

Create a custom interface for the component—a Macromedia Flash MX movie that lets users enter values for the component parameters. 
If you don't create a custom interface, users enter parameter values in the default component Property inspector interface.

Create a Live Preview for the component, to enable users to preview the effects of different parameter values while they work in the 
Macromedia Flash MX authoring environment. If you don't provide a Live Preview, users can view the effects of parameter values by using 
the Test Movie feature.

Create a custom icon to display next to the component name in the Library panel, the Movie Explorer, and the Components panel. If you 
don't create a custom icon, you can use the default component icon that is provided with Macromedia Flash MX.

Add a text description of the component that describes the component for users. You can add the description as plain text or as an XML 
item. Descriptions appear in the Reference panel.
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Component Definition dialog box
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Create the component movie clip

To create the component, first you'll add a text box to enter a label for the button. Then you'll create a new movie clip that contains the 
button and the text box. Finally, you'll create a new layer in the component movie clip and add the ActionScript with the parameter 
variables.

Open the file component_finish.fla if you want to refer to it as you work.

1 Open the component_start.fla file that you downloaded.

2 Choose File > Save As and save the file as component_start_yourname.fla (add your name to the filename to avoid overwriting 
the start file).

3 Click the Insert Layer button in the Timeline to create a new layer. Name the layer Label.

4 Select the first frame of the new layer in the Timeline, then select the Text tool and drag on the Stage to create a text box 
approximately the size of the button.

It's OK if the text field isn't exactly on top of the button. You'll align them later in this procedure.

5 Enter placeholder text for the button label. For example, we entered the label "Cancel."

6 Select the text box on the Stage.

7 Choose Window > Properties if the Property inspector is not visible.

8 In the Property inspector, select Dynamic Text for Text Type, Arial for Font, 14 for Font Size, Center Justify for Justification, and 
deselect Selectable (the button to the right of the Line Type pop-up menu). Type labelFont for Instance Name.

9 With the Arrow tool, select the button and the text box on the Stage.

10 Choose Window > Align to view the Align panel.

11 Click Align Horizontal Center (the second button from the left in the Align row) and Align Vertical Center (the second button from the 
right in the Align row) to align the text box on top of the button. Close the Align panel.

Select the text field with the Text tool and resize the text field if it is too large. It should not be larger than the button.

12 With the button and the text box still selected, choose Insert > Convert to Symbol or press F8 to create a new symbol.

13 In the Convert to Symbol dialog box, type component for the symbol Name. For Behavior, select Movie Clip. Make sure the center 
registration point is selected. Then click OK.

14 Save the file.

Save the file frequently as you work to avoid losing changes.

©1995-2002 Macromedia, Inc. All rights reserved.

Use of this website signifies your agreement to the Terms of Use.

Privacy | Site Map | Contact us | Accessibility

 

http://www.macromedia.com/support/flash/applications/creating_comps/creating_comps03.html [1/05/2002 5:53:40 PM]

http://www.macromedia.com/help/accessibility.html
http://www.macromedia.com/
http://www.macromedia.com/macromedia/
http://www.macromedia.com/sitemap/
http://www.macromedia.com/international/selector/
http://www.macromedia.com/help/
http://www.macromedia.com/store/
http://www.macromedia.com/downloads/
http://www.macromedia.com/desdev/
http://www.macromedia.com/support/
http://www.macromedia.com/software/
http://www.macromedia.com/mediapref.cgi?m=f6&r=self
http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash
http://www.macromedia.com/
http://www.macromedia.com/software/
http://www.macromedia.com/software/flash/
http://www.macromedia.com/support/flash/
http://www.macromedia.com/support/flash/applications_building.html
http://www.macromedia.com/support/flash/applications/creating_comps/index.html
http://www.macromedia.com/help/copyright.html
http://www.macromedia.com/help/copyright.html
http://www.macromedia.com/help/privacy.html
http://www.macromedia.com/sitemap/
http://www.macromedia.com/macromedia/contact/
http://www.macromedia.com/help/accessibility.html


Macromedia Flash - Creating components in Macromedia Flash MX: Add ActionScript to the component

 

 Home > Products > Flash > Support > Building Applications

Add ActionScript to the component

Now you'll add ActionScript containing variables associated with the parameters for the component.

1 With the component_start_yourname.fla open, click the Insert Layer button in the Timeline to create a new layer. Name the layer 
Actions.

2 Select the first frame of the new layer.

3 Choose Window > Actions or press F9 to view the Actions panel.

4 Open the Actions panel Options menu and choose Expert Mode so that you can type directly in the Script pane.

5 In the Actions panel, type (or copy and paste) the following code into the Script pane to declare the parameter variables:

buttonLabel.textColor = labelColor;
myTextFormat = new TextFormat();
myTextFormat.font = labelFont;
buttonLabel.setTextFormat(myTextFormat);

This code identifies three variables, labelColor , labelFont , and myTextFormat (defined by the function TextFormat ), which 
control the font and color of the button label. The content of the label is controlled by a variable called label , which you will use 
later in this tutorial.

6 Save the file.
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Define the parameters

To add parameters to the component, you will use the Component Definition dialog box. When you create a parameter, you give it a 
name, indicate the variable it is associated with, assign it a value, and specify a type. You will create three parameters: Label, for the label 
text of the button, Label Font, for the font used in the label text, and Label Color, for the fill color of the label text.

1 Select the component movie clip in the Library panel (Window > Library).

2 Click the options menu control in the upper right of the Library panel and choose Component Definition from the options menu.

3 In the Component Definition dialog box, click the Add Parameter (+) button to add a parameter.

4 For Name, type Button Label.

The name appears in the Parameters pane in the dialog box.

5 For Variable, type label.

6 For Type, select String from the pop-up menu.

Select the Type before you enter the Value. If you select the Type after entering the Value, the Value will be set to default.

7 For Value, type Cancel (or the label that you added to the button in step 3 in the procedure under Create the component movie 
clip).

Parameters pane with name, variable, value, and type entered

8 Repeat steps 3 through 7 for two additional parameters, Label Font and Label Color:

Click the Add Parameter (+) button to add a new parameter. Type Label Font for Name, labelFont for Variable, Font Name for 
Type, and Arial for Value.

Click the Add Parameter (+) button to add another new parameter. Type Label Color for Name, labelColor for Variable, Color for 
Type, and #000000 for Value (the default value-the hexadecimal value for black).

9 Under Options, select Parameters Are Locked in Instances to prevent users from adding or deleting parameters in instances of the 
component.

Deselecting this option enables users to add or delete parameters in instances of the component.

10 Select Display in the Components Panel to include the component in the Components panel.

11 For Tool Tip Text, type Pulsating Button.

The tooltip text appears when you roll over the component name in the Components panel.

12 

Click the Component Icon button and make sure that Default Icon is selected in the icon list.

The default icon can be used for any component. If you create a custom icon for the component, you select the default icon in the 
list to reference the custom icon that you create. You'll learn to create a custom icon in the next section.

13 Click OK to close the Component Definition dialog box.

14 Save the file.
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Create a custom icon

Next, you will specify a custom icon for the component. When you add the component to a movie, the icon appears next to the component 
name in the Components panel (if you selected Display in Components Panel in the Component Definition dialog box).

Note: You must place the FLA file for the component into the Components folder in the Macromedia Flash MX application folder in order 
for the component name and icon to appear in the Macromedia Flash MX user interface. You will do this as the last procedure in this 
tutorial.

We have provided a bitmap image, named "icon", for the sample component. The bitmap is in the Library. To use the bitmap provided for 
the component custom icon, begin at step 6 in the procedure below.

To create and import your own bitmap image for the custom icon, follow steps 1-5 in the procedure below. Then continue with the 
procedure to specify the bitmap as a custom icon. The icon does not need to be identical to the component, but it should give users an 
idea of the component's appearance. We created a round button for our icon, because it fit better than a rectangular button in the icon 
dimensions.

1 In a graphics application, such as Macromedia Fireworks, create a bitmap image measuring 20 x 20 pixels, which represents the 
component. (You can also create an image in Macromedia Flash MX and save it as a PNG file.)

2 Save the bitmap.

3 In Macromedia Flash MX, open the sample component file and open the library for the component.

4 Choose File > Import to Library.

5 Select the bitmap icon image in the Import to Library dialog box and choose Open.

6 In the Library panel, create a folder named FCustomIcons.

7 Place the bitmap image inside the FCustomIcons folder.

8 Select the bitmap image inside the FCustomIcons folder, and double-click the bitmap name to edit the name.

9 Rename the bitmap image component.

The icon bitmap in the FCustomIcons folder must have exactly the same name as the component movie clip in order for the icon to 
function correctly.

10 Click the Close box in the upper right (Windows) or upper left (Macintosh) corner of the Library to close it. Then reopen the Library 
to see the custom icon displayed next to the component name.

11 Save the file.
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Add a description

You can add a plain text description or an XML description to help users understand the purpose or function of the component. Both types 
of descriptions appear in the Reference panel. With the XML description, you can also add the component name to the Actions toolbox in 
the Actions panel, and to the contents list in the left pane of the Reference panel.

Note: Reference panel descriptions for components are not supported in Macromedia Flash 5.

 
Add a plain text description
Here, you will add a text description by simply entering the text in the Description box in the Component Description dialog box.

1 Select the component in the Library panel (Window > Library).

2 Choose Component Definition from the Library options menu.

3 In the Component Definition dialog box, click the Set button next to the Description text box.

4 In the Component Description dialog box, select Description Is Plain Text.

5 Enter the text description Blue pulsating button with text label in the Description text box and click OK.

The plain text description will be viewable in the Reference panel after you add the component files to your Macromedia Flash MX 
application folder (the final procedure in this tutorial).

To view the plain text description when you add the component to Macromedia Flash MX, you select an instance of the component 
on the Stage and click the Help button in the Property inspector, then choose Help On This Component from the pop-up menu.

 
Add an XML description
As an alternative to a text description, you can add an XML description. You create an XML document to add a custom action to the 
Actions panel toolbox and another custom action to the Reference panel. You place the XML document with the custom actions in the 
Configuration/ActionsPanel/CustomActions folder in the Macromedia Flash MX application folder.

We included the XML file, comp.xml, for you to use to verify your XML code, or to use instead of creating your own XML file.

The custom actions are enclosed in the tags <customactions> and </customactions> . The custom action to place the component 
inside the Actions panel toolbox is enclosed in the tags <actionspanel> and </actionspanel> . If you are placing the component 
inside a subfolder in the Actions panel, the action also includes tags for the subfolder. Inside the <actionspanel> tags, the action 
includes a string name tag with the component symbol name, a tipText tag with tooltip text, and a text tag with the component name 
formatted as an ActionScript function (the component name followed by empty parentheses, ()).

For example, this is the Actions panel custom action code for the sample component:

<actionspanel>
<string name ="component" tipText = "Pulsating button" text = "component()">
</actionspanel>

The action for the Reference panel is enclosed inside the tags <reference> and </reference> . It includes the path to the component 
in the Actions toolbox and description text for the component, as well as a title for the description, if desired. The title and description text 
can use any of the HTML tags supported in Macromedia Flash HTML fields (including <A> , <B> , <FONT COLOR> , <FONT FACE> , <FONT 
SIZE> , <I> , <P> , and <U>) .
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For example, this is the Reference panel custom action code for the sample component:

<reference path="component">
<p class="titleStyle">Custom Component</p>
<p>Blue pulsating button with text label.</p>
</reference>

The two actions together are nested inside the <customactions> tags in the XML document.

1 Use an HTML editor such as Macromedia Dreamweaver to create an XML document with the custom actions for the Actions panel 
toolbox and the Reference panel, following the syntax described above.

Note: It is recommended that you do not cut and paste the sample actions above into an HTML editor, because certain characters, 
such as quotation marks, may not format consistently for XML syntax.

2 Add the XML document to the Configuration/ActionsPanel/CustomActions folder in the following location.

For Windows operating systems:

Windows 2000 or XP: C:\Documents and Settings\user\Application Data\Macromedia\Flash MX\

Windows 98 or ME: C:\Windows\Application Data\Macromedia\Flash MX\

Windows NT: Windows directory\profiles\user\Application Data\Macromedia\Flash MX\

Note: If you cannot find the Configuration\ActionsPanel folder nested inside the Application Data folder, go to the the Folder Options 
settings for your operating system, and make sure the Hidden files and folders option is set to show hidden files and folders. See 
your operating system documentation for more information.

For Macintosh operating systems:

Macintosh OS X: Hard Drive/Users/Library/Application Support/Macromedia/FlashMX/

Macintosh System 9.x, single user: Hard Drive/System folder/Application Support/Macromedia/Flash MX/

Macintosh System 9.x, multiple users: Hard Drive/Users/user/Documents/Macromedia/FlashMX/

3 Restart Macromedia Flash MX.

4 Choose Window > Reference.

The "component" entry should appear in the Actions list in the left pane of the Reference panel.

5 Click the component entry.

The component title and description should appear in the right pane of the Reference panel. Now you need to set the Reference 
panel description in the Component Definition dialog box.

6 Select the component in the Library panel (Window > Library).

7 Choose Component Definition from the Library options menu.

8 In the Component Definition dialog box, click the Set button next to the Description text box.

9 In the Component Description dialog box, select Description Is a Reference Panel Item.

10 In the Reference Panel Item text field, type component, or scroll in the Actions toolbox list and select component from the list.

11 Click OK to close the Component Description dialog box.

The (Reference Panel) identifier and the component name appear in the Description text box. The plain text description you entered 
in the previous procedure is deleted.

12 Click OK to close the Component Definition dialog box.

The XML description will be viewable in the Reference panel after you add the component files to your Macromedia Flash MX 
application folder (the final procedure in this tutorial). The component name will appear in the left pane of the Reference panel, and 
the description will appear in the right pane when you click the component name.

13 Save the file.
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 Home > Products > Flash > Support > Building Applications

Create a Live Preview movie

To create a Live Preview movie for a component, you will make a copy of the component FLA file and add ActionScript to pass the 
parameter values to the Live Preview movie during playback. Then you will create the SWF movie. In the procedure that follows this one, 
you will set the path to the Live Preview movie in the component_start_yourname.fla file.

If you want to use the preview.swf sample movie provided instead of creating your own, go to the next procedure, Set the path to the Live 
Preview movie.

1 With the component_start_yourname.fla open in Macromedia Flash MX, make sure you have saved the latest changes to the file.

2 Choose File > Save As.

3 Name the file preview.fla and save it in the same location as component_start_yourname.fla.

The preview movie needs to be exactly the same size as the component (not the size of the background layer on which the 
component appears) so you'll move the contents of the preview.fla file and resize the Stage.

4 With the component instance selected on the Stage, enter 0 for X and Y in the Property inspector for the component (Window > 
Property). The component instance moves to the upper left corner of the Stage.

Note: Macromedia Flash MX may change the X value to 0.1. That's OK. It won't interfere with the procedure.

5 Select the background on the Stage and delete it.

6 Select the component instance on the Stage.

7 In the Property inspector, select the value for Width (W) and press Control+C (Windows) or Command+C (Macintosh) to copy the 
value.

8 Click in the work area outside the Stage.

9 In the Property inspector for the document, click the Size button (which displays the width and height values).

10 In the Document Properties dialog box, select the value for (width) and press Control+V (Windows) or Command+V (Macintosh) to 
paste the value from the component into the field. Click OK to close the Document Properties dialog box.

11 Select the component instance on the Stage and repeat steps 7-10 to copy and paste the Height value for the component into the 
document. The Stage is now the same size as the component instance.

The preview.fla movie actually needs to contain an instance of the button symbol and a text field (the separate elements of the 
component) and not an instance of the component itself. You'll delete the component instance and add the separate elements to the 
Stage.

12 Select the component instance on the Stage and delete it.

13 Drag an instance of the button symbol from the Library to the Stage. Use the arrow keys to position the instance precisely within the 
boundaries of the Stage.

14 Select the Text tool. On the layer that contains the button, drag to create a new text field on top of the button instance on the Stage. 
Enter Cancel (or whatever text you created for the component movie clip).

15 In the Property inspector, select Dynamic Text for Text Type, Arial for Font, 14 for Font Size, Center Justify for Justification, and 
deselect Selectable. Type buttonLabel for Instance Name. Type xch.label for Variable (Var).

16 Choose Window > Align to view the Align panel.

17 Click Align Horizontal Center (the second button from the left in the Align row) and Align Vertical Center (the second button from the 
right in the Align row) to align the text box on top of the button. Close the Align panel.

18 Use the arrow keys to position the button and text field precisely inside the boundaries of the Stage, if necessary.

19 Save the file.
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20 Select the Button layer and choose Insert > New Symbol to create an empty movie clip symbol and name it xch. Click the Back 
button at the top left of the document window to exit symbol-editing mode and return to the main Timeline.

21 Place an instance of the empty movie clip on the Stage and name the instance xch in the Property inspector.

The xch movie clip instance serves as a placeholder through which values for the parameters are passed.

22 Select the Actions layer and open the Actions panel. Select the code in the Script pane and delete it.

23 Enter the following code in the Script pane:

myTextFormat = new TextFormat();
function onUpdate (){
        buttonLabel.textColor = xch.labelColor;
        myTextFormat.font = xch.labelFont;
        buttonLabel.setTextFormat (myTextFormat);
}

This code creates a function that updates the color and font of the button label when a user updates the parameters for the 
component. The label content is updated via the xch.label variable assigned to the text box in step 15.

24 Save the file and choose Control > Test Movie to create the SWF file for the preview movie.

25 When the preview.swf movie appears in the Macromedia Flash Player test window, close the Player window.
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 Home > Products > Flash > Support > Building Applications

Set the path to the Live Preview movie

Next, you will use the Component Definition dialog box to link the Live Preview movie to the component. You can embed the Live Preview 
movie in the component, or link the Live Preview movie to the component as an external file. Embedding the Live Preview movie makes it 
simpler for users on other systems to access the movie, because the Live Preview movie is included with the component movie file.

1 Return to the component_start_yourname.fla document.

2 Select the component in the Library panel and choose Component Definition from the Library options menu.

3 In the Component Definition dialog box, click the Set button to the right of the Live Preview field.

4 In the Live Preview dialog box, select Live Preview With SWF File Embedded in FLA File to embed the Live Preview movie in the 
component_start_yourname.fla file.

Choosing Live Preview in External .SWF File links the Live Preview movie to the component_start_yourname.fla file. 

Note: We embedded the Live Preview movie in the component_finish.fla sample file, so that you wouldn't have to reset the path to a 
linked file to view the Live Preview movie.

5 Enter the path for the preview.swf movie in the text box, or click Browse and navigate to the preview.swf movie.

6 Click OK to close the Live Preview dialog box, and click OK again to close the Component Definition dialog box.

7 Save the file.
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 Home > Products > Flash > Support > Building Applications

Create a custom interface for a component

A custom interface is a Macromedia Flash MX movie that lets a user enter values for the component parameters. The custom interface 
replaces the interface of the component Property inspector. As with the Live Preview movie, you will use an Exchange movie clip, named 
xch, to pass parameter values to the component.

We created a custom interface for the sample component with a text box for entering the button label, a scroll list for selecting the label 
font, and text boxes for red, green, and blue color values. We used the built-in ScrollBar and ComboBox Macromedia Flash UI 
components to create the interface. We included both the UI.fla document and the UI.swf movie. You can open the FLA file to see how we 
built the custom interface movie.

If you want to use the UI.swf sample movie provided instead of creating your own, go to the next procedure, Set the path to the custom 
interface movie.

This interface simply replicates the default interface displayed in the component Property inspector. However, you can create additional 
interface elements to make it easier for users to add parameter values. For example, for the sample component, you might add sliders for 
selecting RGB values.

Custom interface with text boxes for Red, Green, Blue, and Label, and pop-up menu and text box for Label font 

The ActionScript code for the custom interface is as follows. Code comments are included to explain each action:

// set default values for color faders.
xch.c1 = 0;
xch.c2 = 0;
xch.c3 = 0;
// populate combo box with a list of the users fonts, and sort 
// them alphabetically.
fontList.setEditable(true);
fontList.setDataProvider(textField.getFontList());
fontList.sortItemsBy("label", "asc");
// 
_root.onEnterFrame = function() {
// set the label font to the selected item in the combo box and
// make sure it remembers the setting when you select/deselect 
// the component.
fontList.onKillFocus = function() {
selecting = false;
};
fontList.onSetFocus = function() {
selecting = true;
};
if (selecting) {
xch.labelFont = fontList.getValue();
} else {
fontList.setValue(xch.labelFont);
}
// set r, g, and b values to 255 if a value larger than 255 is entered.
for (i=1; i<=3; i++) {
if (xch["c"+i]>255) {
xch["c"+i] = 255;
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}}
// combine the r, g, and b values into one using bitwise 
// shift and bitwise OR, and use that value for the label color.
xch.labelColor = (xch.c1 << 16 | xch.c2 << 8 | xch.c3);
};

The ActionScript code required to create a custom interface can become somewhat complex, depending on the number and type of 
parameters in your component and the type of interactivity you create.

Note: For more examples of components that use custom interfaces, see the samples described in Help > Samples > Feature highlight: 
Components, Live Preview, and Custom UI.

1 Choose File > New to create a new Macromedia Flash document and name it UI.fla.

2 Create the interface elements that the user will interact with to enter parameter values—for example, a pop-up menu, a slider, radio 
buttons, or drag-and-drop menu items.

3 Choose Insert > New Symbol to create an empty movie clip symbol and name it xch. Place an instance of the empty movie clip on 
the Stage in Frame 1 and name the instance xch.

4 Add ActionScript code to the xch instance to capture the parameter values entered by the user and copy them to the xch instance.

5 Choose Control > Test Movie to create the UI.swf movie for the custom interface. When the UI.swf movie appears in the 
Macromedia Flash Player test window, close the window.

6 Save the UI.fla file and close the file.

©1995-2002 Macromedia, Inc. All rights reserved.

Use of this website signifies your agreement to the Terms of Use.

Privacy | Site Map | Contact us | Accessibility

 

http://www.macromedia.com/support/flash/applications/creating_comps/creating_comps10.html (2 of 2) [1/05/2002 5:54:22 PM]

http://www.macromedia.com/support/flash/applications/creating_comps/index.html
http://www.macromedia.com/help/copyright.html
http://www.macromedia.com/help/copyright.html
http://www.macromedia.com/help/privacy.html
http://www.macromedia.com/sitemap/
http://www.macromedia.com/macromedia/contact/
http://www.macromedia.com/help/accessibility.html


Macromedia Flash - Creating components in Macromedia Flash MX: Set the path to the custom interface movie

 

 Home > Products > Flash > Support > Building Applications

Set the path to the custom interface movie

1 Return to the component_start_yourname.fla file.

2 To create the path to the custom interface movie, select the component in the Library panel and choose Component Definition from 
the Library options menu.

3 In the Component Definition dialog box, click the Set button to the right of the Custom UI field.

4 In the Custom UI dialog box, select Custom UI With SWF File Embedded in FLA File to embed the custom interface movie in the 
component_start_yourname.fla file.

Choosing Custom UI in External .SWF File links the custom interface movie to the component_start_yourname.fla file. 

Note: Macromedia Flash 5 does not support embedded custom interface movies. If you plan to save your component as a 
Macromedia Flash 5 SWF movie, you should link the custom interface movie as an external file.

5 For Display, choose Display in Property inspector.

If the custom interface for your component is too large to easily be displayed in the Property inspector, select Display in Component 
Parameters Panel.

Note: Macromedia Flash 5 does not support the Property inspector for components. If you save your component in Macromedia 
Flash 5 format and open it in the Macromedia Flash 5 authoring tool, the custom interface is displayed in the Component 
Parameters panel.

6 Enter the path for the UI.swf movie in the text box, or click Browse and navigate to the Custom UI movie.

7 Click OK to close the Custom UI dialog box, and click OK again to close the Component Definition dialog box.

8 To view the custom user interface, select the component on the Stage. Open the Property inspector, if it is not visible, then click the 
Parameters tab at the bottom of the Property inspector.

If you selected Display in Property inspector in step 5, the custom interface should appear in the Property inspector.

9 Save the file and close it.
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 Home > Products > Flash > Support > Building Applications

Use the component in Macromedia Flash documents

To add the component to the Macromedia Flash MX application, you place the component files into the Components folder inside the 
Macromedia Flash MX application folder on your hard drive.

To make the component available to users on other systems, provide the users with a folder that contains all the files associated with the 
component, including the component movie clip symbol and any external files for Live Preview and custom interface, if available.

1 Place the component_start_yourname.fla file, and the preview.swf and custom-ui.swf movies, into the Components folder in the 
location indicated below for your operating system.

For Windows operating systems:

Windows 2000 or XP: C:\Documents and Settings\user\Application Data\Macromedia\Flash MX\Configuration\Components

Windows 98 or ME: C:\Windows\Application Data\Macromedia\Flash MX\Configuration\Components

Windows NT: Windows directory\profiles\user\Application Data\Macromedia\Flash MX\Configuration\Components

Note: If you cannot find the Configuration\Components folder nested inside the Application Data folder, go to the the Folder Options 
settings for your operating system. Make sure the Hidden files and folders option is set to show hidden files and folders. See your 
operating system documentation for more information.

For Macintosh operating systems:

Macintosh OS X: Hard Drive/Users/Library/Application Support/Macromedia/FlashMX/Configuration/Components

Macintosh System 9.x, single user: Hard Drive/System folder/Application Support/Macromedia/Flash MX/Configuration/Components

Macintosh System 9.x, multiple users: Hard Drive/Users/user/Documents/Macromedia/FlashMX/Configuration/Components

2 Restart Macromedia Flash MX.

3 Choose Window > Components.

4 Click the pop-up menu bar below the title bar in the Components panel, and choose the button_start_yourname item from the menu.

The component should appear in the Components panel, with the custom icon.

5 Drag the component from the Components panel to add it to a movie.
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Create your own components

Use the procedures explained in this tutorial to create your own components. Components can be as simple or as complex as your design 
and scripting abilities allow. With moderate scripting capabilities, you can create components that make it easy for users to add interactive 
elements to their movies, or that enable you to reuse an interactive element multiple times after you create it.
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