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Website Planning and Design 
Module 1 Lab 

Objectives 
After completing this lab, you should be able to: 

! Plan and design two e-commerce solutions. 

! Create the basis for an e-commerce solution questionnaire. 
 
 Note 

This is a conceptual lab only; there are no right or wrong answers. 
 

Requirements 
To complete the lab activities, you must have reviewed the materials found in the 
HP E-Commerce WBT. 

 



HP Internet Security and E-Commerce Solutions 

L1 – 2 Rev. 2.41 

Planning Different Solution Types 
Given the follow scenario about two fictitious companies, complete the questions 
regarding implementing e-commerce solutions. 

Scenario 
You are planning two websites: one for a start-up company called Bang Ware Inc. 
and another for a 25-year-old service company called Little Duffers. The following 
table provides information about each company. 
 
 Bang Ware Inc. Little Duffers 
Business Sale of new retail clothing that 

has been altered to look used 
or weather-beaten 

Personal golf instruction to 
school-aged children 

Target market segments ! North America 
! Affluent 
! Ages 16-21 

! North America and Europe 
! Affluent 
! Ages 25-65 

Current IS infrastructure ! Limited IS infrastructure 
! External ISP provided email 
! No significant enterprise 

systems 
! Key personnel have IT 

backgrounds 

! Advanced IS infrastructure. 
! Multiple file and print 

servers, application 
servers, database servers 

! Help-desk and IS functions 
are outsourced 

Current advertising ! Hard-copy catalog 
! Word-of-mouth 

! Magazine ads 
! Trade shows 
! Mass media 
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Considerations 
Rate the following items on a scale of 1 to 10 (1 being least important and 10 
being most important), based on their importance to the implementation of an e-
commerce solution for each company.  

1. Importance of an e-commerce site to company success: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

2. Importance of outsourcing e-commerce components: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

3. Importance of web-based advertising: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

4. Importance of transaction security: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

5. Importance of implementing a cost-effective load balancing solution: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

6. Importance of logging and tacking site visitors: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

7. Importance of maintaining a highly available site: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

8. Importance of firewall and document security: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

9. Importance of a phased approach to creating and e-commerce site: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  
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10. Importance of planning the integration of an e-commerce solution: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

11. Importance of secure communication with business partners: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  

12. Importance of implementing an Internet-based EDI solution: 

Bang Ware .........................................................................................................  

Little Duffers .....................................................................................................  
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E-Commerce Design Plan 
In the space provided, give an overview of how you would design a DISA solution 
for each company. 
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Developing an E-Commerce Questionnaire 
Use the questions you completed in the first half of this lab and then add your own 
to create the basis of your e-commerce questionnaire. 

In the Lab Summary, you will compare answers with other students to further 
develop your questionnaire. 
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Lab Summary 
Compare answers from other students to further develop your e-commerce 
planning and design skills and help develop your questionnaire. 
 
 Note 

The questionnaire should be considered a work-in-progress. The constantly 
changing infrastructure of e-commerce should facilitate the need to constantly 
update and revise your planning and design skills. 
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Sizing an E-Commerce Solution 
Module 2 — Lab 1 

Objective 
After completing this lab, you should be able to use the ProLiant Sizer for E-
Commerce Solutions to recommend an HP e-commerce solution. 

Requirements 
! Internet Explorer 5.5 or later 

! Classroom access to the Internet 
 
 Note 

If Internet access is not available in the classroom, most of the Sizer screens 
are shown in the lab documentation for review and discussion. 
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Introduction 
The ProLiant Sizer for E-Commerce Solutions is a configuration-estimating tool 
that assists the user with sizing HP hardware for the following applications that 
will be used in this course:  

! Microsoft Internet Information Services for Windows 2000  

! Microsoft Commerce Server for Windows 2000  

The Sizer provides a valid HP hardware configuration, given a specified peak load 
based on the information provided in the automated interview. The complete Bill 
of Materials (BOM) for each server recommended is provided in a series of HTML 
pages that can be printed and used for budgeting and ordering the recommended 
HP hardware. 
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Scenario 
Parker Design Inc., of Sante Fe, New Mexico, is a relatively small designer and 
manufacturer of mountain bike components. The company sells its products to 
distributors and retailers; however, the company would like to sell products and 
services over the Internet to consumers. 

There is no web server in place at the Parker office. The current website serves as 
a source of information about the company. Although there is an electronic 
catalog, there are no mechanisms in place for ordering. An ISP hosts the website. 

Currently, the catalog consists of less than 100 products. However, Parker 
develops an average of 15 new products each year and some products are built to 
order. 

The e-commerce solution must be scalable for potential growth yet economical. 
Because Parker only has two IT employees, the hardware must have remote 
management capabilities. 

Parker sells to more than 500 distributors and retailers. The website must be 
capable of handling catalog browsing, special orders, and online purchases. 

Use the ProLiant Sizer for E-Commerce Solutions tool to generate a hardware 
configuration based on the company’s needs and plans for growth. 
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Connecting to the Compaq E-Commerce Solution Sizer 
To access the Compaq E-Commerce Solution Sizer: 

1. From a web browser, connect to 
http://www.hp.com/solutions/activeanswers. The ActiveAnswers Welcome 
page displays. 

2. Click Tools in the left menu. 

3. A list of tools for sizing and configuring solutions are listed. Click View the 
available sizers under Solution Sizers. If a Security Alert window displays, 
click Yes to proceed. 

4. The ActiveAnswers website requires user registration. If you are a registered 
user, enter your user name and password in the fields. Click submit. 
Otherwise, click Need to register? to enter the necessary information to 
create an account. 

5. Under Online Sizers, click Proliant Sizer for E-Commerce Solutions. The hp 
e-commerce solution sizer introduction page displays. 

6. Click the HP E-Commerce Solution Sizer link at the bottom of the page. The 
Sizer opens a new window. 

 
 

7. In the license and disclaimer agreement dialog box, select Agree → Next. The 
Solution Options screen displays. 
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8. In the Solutions Options dialog box, select Microsoft Commerce Server 2000 
for Windows 2000 and click Next. The Site Profile Selection screen displays. 
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The three site profiles consist of a single-server solution and DISA solutions. 
Selecting the correct profile is dependent on: 

! Concurrent users 

This is the peak number of users expected to hold a concurrent 
connection during the busiest times. If future growth vastly exceeds the 
capacity of the current site, then one of the more expandable solutions 
should be considered. It is important to plan the architecture and 
hardware for an e-commerce site according to perceived growth. 

! Transactions per minute 

The estimated transaction load is the number of transactions per minute 
that can be expected on the e-commerce site. This number is significant 
in that it has been tested against the servers profiled in the sizer to 
determine the type and number of ProLiant servers required to fulfill the 
site needs. Server capacity limits are based on a number of factors, 
including the percentage of transactions such as browsing, basket 
operations, purchases, and the relative costs of each activity. 

The profile options are: 

! Entry Level 

Scalable and affordable, this e-commerce storefront solution is ideal as a 
dedicated storefront supporting up to an average of 425 concurrent users 
and 25 transactions per minute. 

With single-server solutions, all content resides on one server. This is 
the recommended solution for small to medium businesses or for 
internal use as Departmental servers. Single-server solutions are 
available in tower and rack form factors. 

! DISA 

Ideal for large enterprises and ISPs, this multiserver configuration 
supports up to an average of 975 concurrent users and 65 transactions 
per minute. 

! DISA H.A. 

With maximum availability and scalability, this solution supports up to 
an average of 1460 concurrent users and 100 transactions per minute. 

DISA solutions are suitable when availability, scalability, and fault 
tolerance are of utmost importance. These solutions implement multiple 
application and data servers. Site content is not the driving factor. With 
a DISA implementation, scalability to handle additional traffic is as 
simple as bringing another server online. DISA solutions are available 
in THE rack form factor only. 
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9. Select the DISA profile and click Next. The Additional Rack Option screen 
displays. 

 
 

10. The Additional Rack Option dialog box selects the 36U Rack by default. 
Click Next. 

11. The Additional Monitor Option screen displays. Select Existing Monitor and 
click Next. 

12. The Remote Insight Board Option screen displays. The Remote Insight 
Lights-Out Edition simplifies remote management by providing graphical 
access and full control of remote servers using a web browser. Select Yes and 
click Next. 

13. The Additional Hardware Redundancy Option screen displays. Select Yes and 
click Next. 

14. The CarePaq Services — Installation and Startup screen displays. The 
Carepaq Services provides the opportunity to purchase one-time hardware 
installation services. Select None and click Next. 

15. The CarePaq Services - On-Site Services screen displays. Select None and 
click Next. 
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16. The Sizer Profile Summary screen lists the basic hardware configuration to 
meet your e-commerce solution performance and scalability requirements. 
Click Next. 

 
 

17. The Submission Option screen displays. Click Next. 
18. The Thank you screen displays. Click Finish. 
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19. If you have an Internet connection, results are presented in a browser 
window. The configuration summary portion of the screen provides you with 
the option to contact HP about the solution, load the solution in Microsoft 
Word 2000, print the solution, or restart the process. 

  
The Detailed Bill Of Materials section allows you to load a consolidated parts 
list in an Excel spreadsheet, load a consolidated parts list in an Excel 
spreadsheet with formulas, or send a parts list by email. 

  
In addition, a recommended rack placement of each system is illustrated and the 
rack layout indicates placement of each system. 
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Lab Summary 
What type of solution was recommended for Parker Design? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

Does the size of a company dictate which e-commerce solution is most suitable? 
Explain. 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Web Server Preparation 
Lab 2.2 

Objectives 
After completing this lab, you should be able to: 

! Create a new Microsoft Internet Information Services (IIS) website. 

! Perform basic IIS 5.0 administration tasks. 

! Optimize Microsoft Windows 2000 for web server performance. 
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Create a Website 
By default, Microsoft Commerce Server installs your site in the IIS Default Web 
Site. To provide additional security for your websites, you should create a new IIS 
website for each site you are planning to install with Commerce Server. When you 
use Commerce Server Site Packager to unpack your site, you can specify that it 
reside in the IIS website you created rather than in the Default Web Site. 

To create a new website: 

1. Create a new folder in the inetpub\wwwroot directory that will store your 
website files. 

2. Click Start → Programs → Administrative Tools → Internet Services 
Manager.  

3. In the Internet Information Services window, right-click the name of the 
computer on which you want to create the new IIS site. Select New → 
Website. 

 
 

4. In the Website Creation Wizard dialog box, click Next. 
5. In the Website Description dialog box, enter a name for the new website. 

This name will display as the site name in Internet Services Manager. Click 
Next. 



Web Server Preparation 

Rev. 2.41 L2.2 – 3 

6. In the IP Addresses and Port Settings dialog box, enter the following 
information: 

 
In this field Enter 
Enter the IP address to use for this 
Website 

Select the IP address assigned to the web 
server from the drop-down list. 

TCP port this Website should use  Do not change the default port address 
(80). 

Host Header for this site You will not add additional sites to this IP 
address. Accept the default, None. 

 
7. Click Next. 
8. In the Website Home Directory dialog box, click Browse and select the 

location for the path. Leave the Allow anonymous access to this Website box 
checked. 

9. Click Next. 
10. In the Website Access Permissions dialog box, select the permissions as 

shown in the following figure and click Next. 

  
11. Click Finish to close the wizard. 
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Optimizing IIS 
It is critical to the success and scalability of your websites and web-based 
applications to design them with performance in mind. Microsoft recommends that 
you complete the following procedures to optimize IIS: 

! Remove irrelevant mappings. 

! For high-volume sites or for benchmarking, set the Performance bar to More 
than 100,000. 

! Disable logging when not needed. 

! If logging is enabled, log to a striped partition with a controller that allows 
write-back caching, especially if you see heavy usage on the log disk. 

 
! Important 

These settings will not be changed in the lab. The steps to change the settings 
are provided so that you can become familiar with the procedures for changing 
the settings if you encounter a situation that requires you to do so. 
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Removing Mappings 

  
IIS checks the extension of each file. Deleting unused mappings can eliminate this 
additional overhead. 
 

! Important 
Do not delete any mappings in this exercise. These steps are provided for 
informational purposes only. 

 
To view the mappings: 

1. From Internet Services Manager, right-click the website created in the 
previous exercise and select Properties. 

2. Select the Home Directory tab. 

3. Click the Configuration button in the Application Settings section. A list of 
mappings displays. 

If you know that your website does not contain content that corresponds to 
the mappings listed in this dialog box, you can delete those unused mappings. 
The .ASP extension is required for Commerce Server Solution Sites. 

4. After you have reviewed the existing mappings, click Cancel → OK. 
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Adjusting Website Performance 

  
The performance bar controls the amount of resources available to IIS. Because 
IIS expects heavy usage, it keeps additional resources available even if they are 
not in use. Adjust the Performance tuning setting only for high-volume sites. 

Adjust the Performance for a High-Volume Site 
From the Internet Services Manager: 

1. Right-click the website created in the previous exercise and select Properties. 

2. Click the Performance tab. 

3. Slide the performance tuning bar to the More than 100,000 setting. 

4. Click OK. 

Bandwidth and Process Throttling  
If your system is a dedicated web server, do not enable these features. This will 
limit the network traffic that can be generated by the web server and the processor 
usage to preserve bandwidth and threads for other applications. 
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Disabling Logging 

 
 

By disabling unneeded logging activity, you free up system resources and enhance 
performance. 

From the Internet Services Manager: 

1. Right-click your new website and select Properties. 

2. On the Website tab, deselect the Enable Logging check box to disable 
logging. 

3. Click OK. 
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Optimizing Logging 

 
 

If logging is enabled on your website, log to a striped partition with a controller 
that allows write-back caching, especially if you see heavy usage on the log disk. 
 
 Note 

Do not change any settings in this exercise. These steps are provided for 
informational purposes only. 

 
From Internet Services Manager: 

1. Right-click your new website and select Properties. 

2. Click the Properties button in the Enable Logging pane. 

3. Click Browse and select a directory that exists on a striped partition. 

4. Click OK → OK. 
5. Exit Internet Services Manager. 
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Optimizing Windows 2000 for Web Server Performance 
HP recommends the following procedures for optimizing Windows 2000 Server 
for optimal web server performance: 

! Remove nonessential system services. 

! Set virtual memory to static. 

! Minimize application performance boost. 

! Maximize server services for network applications. 

! Edit the Windows 2000 registry by: 

• Increasing the NIC maximum connection retry value. 

• Increasing the TCP/IP User Port and Window Size. 

• Releasing processor control on specific network cards. 
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Removing Nonessential System Services  

 
 

When implementing a web server, some Windows 2000 services are unnecessary 
and can be eliminated. Some services that can typically be eliminated include: 

! License Logging Service 

! Plug and Play 

! Print Spooler 

To remove a service:  

1. Click Start → Programs → Administrative Tools → Services. 
2. Right-click the service to be removed and click Properties. 

3. Select Manual for Startup Type. 

4. Click OK. 
The service will not start when Windows 2000 is restarted. 
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Setting Virtual Memory to Static  

 
 

A paging file that must constantly expand and shrink requires additional processor 
and I/O overhead. Set the size of the paging file at two or two-and-a-half times the 
amount of installed physical memory. 

1. From Control Panel, double-click the System icon. 

2. Select the Advanced tab. 

3. Click Performance Options. 
4. In the Virtual memory pane, click Change. The Virtual Memory dialog box 

displays. 

5. Set Paging file size for selected drive to a static size, such as 500MB, to 
minimize paging on the disk subsystem. Enter this value in both the Initial 
size and Maximum size fields. (A general rule is to set virtual memory to 
twice the amount of physical memory installed in the server, up to a 
maximum of 1GB.) 

6. Click Set → OK. 
7. Restart the system. 
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Lab Summary 
View your website properties in IIS. 

1. Click Properties. The Default Website Properties dialog box displays, which 
is used to adjust the settings for the web service.  

 
 

2. Click the Documents tab. What file loads by default when a browser connects 
to this site? 

............................................................................................................................  

3. Click the Directory Security tab. Click Edit in the IP address and domain 
name restrictions pane. By default, who can access this website? 

............................................................................................................................  

4. Click Edit in the Anonymous access and authentication control pane of the 
Directory Security tab. Click Edit next to Allow Anonymous Access. What 
user account is used for anonymous access? 

............................................................................................................................  

Click OK → OK → OK to close the dialog boxes. 
 



 

2.41 L2.3 – 1 

Prerequisite Software 
Installation and Configuration 

Module 2 — Lab 3 

Objectives 
After completing this lab, you should be able to: 

! Install SQL Server 2000 database and analysis components on the database 
server. 

! Install SQL Server 2000 database and analysis service packs on the database 
server. 

! Install SQL Server 2000 Client database and analysis components on the web 
server and workstation. 

! Install SQL Server 2000 database and analysis service packs on the web 
server and workstation. 
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Prerequisite Software 
SQL Server is a prerequisite for both Microsoft Content Management Server 
(MSCMS) and Commerce Server implementations. For MSCMS, the web server 
content resides in the database. Commerce Server, however, uses SQL Server to 
store product catalogs and user profile information. 

Although Active Directory is not required for Commerce Server if you are 
implementing a retail site, it is required for a supplier solution. Furthermore, 
MSCMS requires Active Directory to be installed because it uses Active Directory 
services interfaces. MSCMS also uses a Windows 2000 domain user account to 
assign rights to security objects. 

Ideally, you need two computers to handle Active Directory efficiently. Each 
serves as a replicated domain controller. 

During the deployment process, be sure to document all server configurations 
(server names, roles, ports, and required services), operating system settings, and 
network configurations. This is a proactive measure that enables you to quickly 
troubleshoot problems or configure additional servers. 
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Installing SQL Server 
1. Connect to the classroom share that contains the SQL Server 2000 

installation files. 

2. Copy the SQL Server 2000 directory to a folder on your server. This 
facilitates faster installation. 

3. Run autorun.exe from the SQL Server 2000 directory to start the Setup 
program. 

4. Select SQL Server 2000 Components. 
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5. Click Install Database Server from the Install Components screen. 

6. The Welcome screen displays. Click Next to start the Installation wizard. 

7. In the Computer Name screen, the name of the computer should be grayed 
out and Local Computer selected. Click Next. 
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8. In the Installation Selection screen, select Create a new instance of SQL 
Server, or install Client Tools. Click Next. 

9. Accept the default information on the User Information screen, and click 
Next. 

10. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

11. Enter the CD key provided by the instructor on the CD-Key screen and click 
Next. 
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12. Select Server and Client Tools as the installation type on the Installation 
Definition screen and click Next. 

13. Click Next on the Instance Name screen for a default installation. 
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14. In the Setup Type dialog box select Custom and click Next. 
15. Click Next to install the components listed. 

16. Ensure that Use a Domain User account is selected in the Services Accounts 
dialog box. Enter the password for the Administrator account. The domain 
name should be the computer name. Click Next. 
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17. In the Authentication Mode screen, select Mixed Mode (Windows 
Authentication and SQL Server Authentication). Enter the same password for 
the sa login as the Administrator account. This is for lab convenience only. 
Duplicate passwords are not recommended in a production environment.  
Click Next. 

 

! Important 
Mixed Mode authentication is the only mode supported by Commerce Server. 

 
 



Prerequisite Software Installation and Configuration 

2.41 L2.3 – 9 

 
 

18. Do not change the default selection in the Collation Settings dialog box. 
Click Next. 

19. Click Next in the Network Libraries dialog box. 

20. Click Next on the Start Copying Files dialog box. 

21. Click Next to begin shutting down tasks. 
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22. Enter 10 in the Per Seat for devices field. Click Continue. 

23. Click Finish to complete the Setup wizard. 
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Installing SQL Server 2000 Analysis Services 
Analysis Services must be installed on the data resource server. Perform the 
following steps to install the SQL Server 2000 Analysis Services. 

1. Navigate to the directory that contains the SQL Server installation files. 

2. Run autorun.exe to start the Setup program. 

3. Click SQL Server 2000 Components. 

4. Click Install Analysis Services. 

 
 

5. The Welcome screen displays. Click Next to start the Installation wizard. 

6. The Software License Agreement screen displays. Click Yes to accept the 
terms. 
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7. Ensure that all components are selected. Click Next to continue. 

8. Click Next to create a data folder in the default destination folder. 

9. Click Next to accept the default Program Folder for the location of program 
icons. 

10. Click Finish to complete the Setup wizard. 

 

 



Prerequisite Software Installation and Configuration 

2.41 L2.3 – 13 

Installing SQL Server 2000 Service Pack for Database Services 
The Service Pack must be installed on the data resource server. 

1. Navigate to the class folder that contains the SQL Server 2000 Service Pack. 

2. Run sql2ksp2.exe. 
 
 Note 

The instructor may use a later version of the SQL Server 2000 Service Pack 
for Database Services, which would result in running a different file name. 

 
3. Click Finish to accept the default installation folder. 

4. Click Yes to create the folder. 

5. Click OK after the package has been extracted. 

6. Run C:\sql2sp2\Setup.bat. 

7. The Welcome screen displays. Click Next to start the Installation wizard. 

8. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

9. There is only one instance of SQL Server so the Default check box is grayed 
out. Click Next on the Instance Name dialog box. 

10. Select The SQL Server system administrator login information and enter the 
password for the sa account. Click Next. 

  
11. Click Next on the Start Copying Files dialog box. 
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12. Click Next to begin shutting down tasks. 

 
 

13. Click Finish to begin installing the software. 

14. Click OK on the prompt to back up databases. 

 
 

15. Select No, I will restart my computer later and click Finish. 
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Installing SQL Server 2000 Service Pack for Analysis Services 
 
 Note 

The instructor may use a later version of the SQL Server 2000 Service Pack 
for Analysis Services, which would result in running a different file name. 

 
1. Run sql2asp2.exe from the class folder. 

2. Click Finish to accept the default installation folder. 

3. Click OK after the package has been extracted. 

4. Run C:\sql2sp2\msolap\install\Setup.exe. 

5. The Welcome screen displays. Click Next to start the Installation wizard. 

6. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

7. Click Finish to complete the Setup wizard. 

8. Restart the server. 
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Starting SQL Server Services 

 
 

1. The SQL Server Service Manager should display in the System Tray after 
system startup. Right-click the SQL Server Service Manager icon and select 
Open SQL Server Service Manager.  

 
 

2. If the SQL Server Service is not running, click the Start/Continue button. 

3. In the Services drop-down menu, select SQL Server Agent, and then click the 
Start/Continue button. 

  
4. Select Auto-start service when OS starts to ensure the Agent starts at server 

startup. 

5. Close the SQL Server Service Manager. 
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Configuring the Administrator Login 
Commerce Server 2000 installation requires access to the Administration database. 
The sa login should not be used for access to the Administration database. For 
security purposes, verify the Administrator login information for the 
Administration database. 

1. On the Data Resource server, select Start → Programs → Microsoft SQL 
Server → Enterprise Manager. 

2. Expand Microsoft SQL Servers → SQL Server Group → the Data Resource 
server name → Security → Logins. 

3. Right-click the Administrator login displayed in the right pane and select 
Properties. 

4. Click the Database Access tab. 

5. Highlight each database and select db_owner as the database role. 

6. Click OK. 

7. Close Enterprise Manager. 
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Installing SQL Server 2000 Client Tools 
The SQL Server 2000 Client Tools must be installed on the web server computer if 
Commerce Server must connect to a remote SQL Server computer. The SQL 
Server 2000 Client Tools include Microsoft Data Access Components (MDAC) 
2.6, which is a prerequisite for installing Commerce Server. 

Perform the following steps to install the SQL Server 2000 Client Tools on the 
web server. 

1. Share the folder on the system that contains the SQL Server installation files. 

2. On the web server, map to the folder that contains the SQL Server installation 
files. 

3. Run autorun.exe from the SQL Server 2000 directory to start the Setup 
program. 

4. Select SQL Server 2000 Components. 

5. Select Install Database Server from the Install Components screen. 

6. The Welcome screen displays. Click Next to start the Installation Wizard. 

7. In the Computer Name screen, the name of the computer should be grayed 
out and the Local Computer option selected. Click Next. 

8. In the Installation Selection screen, select Create a new instance of SQL 
Server, or install Client Tools. Click Next. 

9. Accept the default information on the User Information screen, and click 
Next. 

10. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

11. Enter the CD key provided by the instructor on the CD-Key screen and click 
Next. 

12. In the Installation Definition screen, select Client Tools Only and click Next. 
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13. In the Select Components screen, accept the default selections and click Next. 
14. Click Next on the Start Copying Files screen. 

15. Click Finish to complete the Setup wizard. 

Installing SQL Server Client Tools on the Workstation 
You will use the workstation to run the Commerce Server Business Desk client. If 
Microsoft Office 2000 is not installed on the workstation, you must install SQL 
Server 2000 Client Tools. MDAC 2.6 and the executables (dCube files) are 
required to build a cube in memory on the Business Desk client computer. 
Microsoft Office 2000 and SQL Server 2000 Client Tools install these features. 

Perform the steps listed in the “Installing SQL Server 2000 Client Tools” section. 
You will need to map to the folder that contains the SQL Server installation files. 
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Installing SQL Server 2000 Analysis Services Client Tools 
Analysis Services Client tools must be installed on the web computer. Perform the 
following steps to install the SQL Server 2000 Analysis Services Client tools. 

1. Navigate to the directory that contains the SQL Server installation files. 

2. Run autorun.exe to start the Setup program. 

3. Click SQL Server 2000 Components. 

4. Click Install Analysis Services. 

5. The Welcome screen displays. Click Next to start the Installation wizard. 

6. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

7. Accept the default installation components, and click Next to continue. 

8. Click Next to create a data folder in the default destination folder. 

9. Click Next to accept the default Program Folder for the location of program 
icons. 

10. Click Finish to complete the Setup wizard. 

Installing SQL Server 2000 Service Pack 
The Service Pack must be installed on the web server. 

1. Navigate to the class folder that contains the SQL Server 2000 Service Pack. 

2. Run sql2ksp2.exe. 

3. Click Finish to accept the default installation folder. 

4. Click Yes to create the folder. 

5. Click OK after the package has been extracted. 

6. Run C:\sql2sp2\Setup.bat. 

7. The Welcome screen displays. Click Next to start the Installation wizard. 

8. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

9. Click Next on the Start Copying Files dialog box. 

10. Click Next to begin shutting down tasks. 

11. Click Finish to begin installing the software. 

12. Select No, I will restart my computer later and click Finish. 
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Installing SQL Server 2000 Analysis Service Pack 
The Service Pack must be installed on the web server. 

1. Navigate to the class folder that contains the SQL Server 2000 Service Pack. 

2. Run sql2asp2.exe. 

3. Click Finish to accept the default installation folder. 

4. Click Yes to create the folder. 

5. Click OK after the package has been extracted. 

6. Run C:\sql2sp2\msolap\install\Setup.exe. 

7. The Welcome screen displays. Click Next to start the Installation wizard. 

8. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

9. Click Finish to begin installing the software. 

10. Select Restart my computer and click Finish. 
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Lab Summary 
You installed SQL Server 2000 on the system designated as the data resource 
server and on the web server. Why do you think it is necessary to install SQL 
Server on the web server? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

If a system functions as the web server and data resource server, which installation 
steps can be eliminated? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

Why is it best to have a dedicated data resource server? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Document Server Configuration 
List any configuration changes made to the servers. This includes any user 
configuration information. 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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............................................................................................................................  
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............................................................................................................................  

............................................................................................................................  
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............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Deploying Commerce Server  
Lab 3 

Objectives 
After completing this lab, you should be able to: 

! Install and configure Microsoft Commerce Server and the Commerce Server 
Service Pack. 

! Install and configure the Commerce Server Retail Solution site. 

! Access the retail website to make purchases. 

! Run and review reports on website activity. 

Requirements 
! Access to a data resource server with: 

• SQL Server 2000 

• SQL Server Service Pack 2 or higher, which includes: 
# ADSI 2.5 or higher 

# MDAC 2.5 or higher 

! Internet Explorer 5 or higher 

! Microsoft Java VM 

! IIS 5 

 

 

 

 



HP Internet Security and E-Commerce Solutions 

L3 – 2 Rev. 2.41 

Installing Commerce Server 
The following steps guide you through installing Commerce Server using the 
complete installation option. You must close all other applications before 
proceeding. 
 
 Note 

When you install Microsoft Commerce Server 2000, do not use "localhost" as 
the computer name in the URL or when you are prompted for the SQL Server 
name. 
You must install Direct Mailer on a local SQL Server. Before installing Direct 
Mailer, verify that SQL Server Agent is started. If it is not started, Direct 
Mailer will not install. 

 
To install Commerce Server: 

1. Run the Setup program from the directory provided by the instructor. The 
Commerce Server 2000 Setup program starts. 

2. Click Commerce Server Installation. 

3. The Welcome screen displays. Click Next to start the Installation wizard. 

4. Ensure that the prerequisites have been met for the Commerce Server 
installation. Click Next. 

5. The Software License Agreement screen displays. Select I accept the terms in 
the license agreement and click Next. 

6. In the Customer Information screen, type the 25-character product key 
provided by the instructor, and then click Next. 

7. In the Destination Folder screen, accept the default installation folder. Click 
Next. 

8. In the Setup Type screen, select Web Server, and click Next. 
9. In the Administration Database Configuration screen, enter the following 

information. 
 

In this field Enter 
SQL Server Computer SQLSRVRn (reflects your student set) 
SQL Server Login Name Administrator 
SQL Server Login Password Enter the password for the Administrator 

account 
 

Click Next. 
 

! Important 
For security purposes, do not use the sa login for access to the Administration 
database. To change the login information for the Administration database 
after it is created, use SQL Server Enterprise Manager. 
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10. In the Service Accounts screen, enter the following information. 
 

In this field Enter 
Username Administrator 
Password Enter the password for the Administrator 
Domain Enter the computer name 

 
Click Next. 

11. Click Install to begin the installation process. 

12. Click Finish to exit the Setup program. The PuP Packages window opens and 
displays the Blank Solution Site. 

13. Restart the web server. 
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Installing Commerce Server Service Pack 
Commerce Server Service Pack contains the latest updates and fixes. Follow these 
steps to install the service pack. 

1. Run CS2KSP2-EN.EXE from the classroom folder. 

2. Click Browse and select a location to extract the files. 

3. Run SP2SETUP.EXE from the location in which the files were extracted. 

4. Commerce Server Service Pack 2 informs you that you must install XML 3.0 
after the Server Pack installation. Click OK. 

5. Click OK to acknowledge that some services will be stopped. 

6. The Welcome screen displays. Click Next to start the Installation Wizard. 

7. The Software License Agreement screen displays. Select I accept the terms in 
the license agreement and click Next. 

8. Click Install to begin the installation. 

9.  Click Finish to complete the Setup wizard. 

There is no need to restart the web server. 

Installing XML Parser 
The Microsoft XML Parser Service Pack provides a number of bug fixes and 
provides server-safe HTTP access. To install the XML Service Pack: 

1. Run MSXML3SP2SETUP.EXE from the classroom folder. 

2. The Welcome screen displays. Click Next to start the Installation wizard. 

3. The Software License Agreement screen displays. Select I accept the terms in 
the license agreement and click Next. 

4. Click Next on the Customer Information dialog box. 

5. Click Install to begin the installation. 

6. Click Finish to complete the Setup wizard. 
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Installing Commerce Server on the Data Resource Server 
Commerce Server must be installed on the data resource server to install the data 
warehouse and analysis services. 

1. Run the Setup program from the directory provided by the instructor. The 
Commerce Server 2000 Setup program starts. 

2. Click the Commerce Server Components. 

3. The Welcome screen displays. Click Next to start the Installation wizard. 

4. Ensure that the prerequisites have been met for the Commerce Server 
installation. Click Next. 

5. The Software License Agreement screen displays. Select I accept the terms in 
the license agreement and click Next. 

6. In the Customer Information screen, type the 25-character product key 
provided by the instructor, and then click Next. 

7. In the Destination Folder screen, accept the default installation folder. Click 
Next. 

8. In the Setup Type screen, select Custom, and click Next. 
9. In the Custom Setup dialog box, modify the feature selections as shown in 

the table and click Next to continue. 

For this feature Select 
Commerce Site Packages Will not be available 
Analysis and Data Warehouse Will be installed on local hard drive 
Predictor Service Will not be available 
Direct Mailer Service Will not be available 
SDK Will not be available 
Administration Tools Will not be available 
Online Documentation Will not be available 

 

10. In the Administration Database Configuration screen, enter the following: 
 

In this field Enter 
SQL Server Computer SQLSRVRn (reflects your student set) 
SQL Server Login Name Administrator 
SQL Server Login Password Enter the password for the Administrator 

account 
 

Click Next. 
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11. In the Service Accounts screen, enter the following information. 
 

In this field Enter 
Username Administrator 
Password Enter the password for the Administrator 
Domain Enter the computer name 

 
Click Next. 

12. Click Install to begin the installation process. 

13. Click Finish to exit the Setup program. 

14. Restart the web server. 
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Installing the Commerce Server Solution Retail Site 
The Commerce Server Solution Sites are ready-to-deploy storefronts. This lab 
unpacks the Solution Sites and deploys the Retail site. You must install Active 
Directory in order to use the Supplier site. 

1. Run CommerceServerSolution.exe from the classroom folder. 

2. The Commerce Server 2000 Solution Sites Setup program starts. Click Next. 
3. The Software License Agreement screen displays. Select I accept the terms in 

the license agreement and click Next. 
4. Click Install to begin the installation. 

5. Click Finish to complete the Setup wizard. 

6. Click Start → Programs → Microsoft Commerce Server 2000 → Commerce 
Site Packager.  

7. In the Commerce Server Site Packager screen, select Unpack from a package 
file (.pup), and then click Next. 

8. In the Unpack dialog box, click Browse. 

9. In the Open dialog box, navigate to the C:\Program Files\Microsoft 
Commerce Server\PuP Packages folder, select retail.pup, and click Open.  

10. When you are returned to the Unpack dialog box, select Custom unpack, and 
click Next. 
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11. When the Data Warehouse dialog box displays, enter the following 

information. 
 
In this field Enter 
Name Enter Data Warehouse n, where n is your 

group number 
Server Enter SQLSRVR 
Database Enter Retail_dw 

 

12. Click Test Connection. If the connection is not successful, click Skip 
Resource. Otherwise, click OK. 
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13. When the first Profiling System dialog box displays, accept the defaults and 
click Next. 

 
 

14. Accept the defaults in the second Profiling System dialog box and click Next 
→ OK. 
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15. In the Unpacking is complete dialog box, review the list of SQL Server 
databases and IIS applications that were created. To review the list of events 
in the Site Packager log file, click View Log File. 

16. Select retail in the IIS applications created during unpacking section and 
click View Selected Application. 
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17. The web browser opens the Retail site; however, no catalog is available. 
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18. Switch to the Site Packager window. Select retailbizdesk → View Selected 
Application to start the Business Desk Client Setup. 

19. When you access the Business Desk Client Setup for the first time, a security 
warning displays. Select Always Trust content from Microsoft Corporation 
and click Yes. 

20. Click Create a new directory and enter BizDesk. Click OK → OK. 
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21. Click Start Business Desk. 

22. To close Site Packager, click Finish.  
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Preparing the Site 
Business Desk is a Commerce Server Management tool that allows you to 
configure, manage, and analyze your website. Before you can open the Retail 
website for business, you must use Commerce Server Business Desk to perform 
the following tasks: 

! Import a catalog 

! Customize shipping methods 

! Publish the catalog to the site 

Import a Catalog 
You can import an existing catalog or create a catalog schema. Due to time 
constraints, in this lab you will import the Books catalog. 

1. Select Catalogs → Catalog Editor. 

  
2. Click the Import Catalog icon and select Import XML from the drop-down 

list. 

3. In the Import XML Catalog dialog box, enter 
<class_folder_location>\booksfull.xml in the File name field. 

4. Click OK when the catalog import is successful. 
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5. Check the Application Log in the Event Viewer to ensure the following 
information events occurred. 

 
Event Description 
Information Creating full text indexes 
Information Importing Catalog “Books” 
Information Commerce Server Catalog Import started 

 
6. Press Alt+P to refresh the Catalog page. Books displays in the Catalog Editor 

list. 

 



HP Internet Security and E-Commerce Solutions 

L3 – 16 Rev. 2.41 

Customize Shipping Methods 
You must specify how Commerce Server should calculate the shipping costs: by 
the weight of the product, by the quantity the users purchase, or by the amount of 
the purchase subtotal.  

1. In the Business Desk screen, select Orders → Shipping Methods. 
2. Click the New Shipping Method icon → Charge by SubTotal. The Charge by 

SubTotal – New screen displays. 

  
3. Enter Standard_Shipping in the Name field. 
4. Use the following table to enter shipping costs by subtotal.  

Price, up to Rate 
Up to $20.00 $4.95 
$20.01 to $40.00 $5.95 
$40.01 to $60.00 $7.95 
$60.01 to $80.00 $10.95 
$80.01 to $100.00 $13.95 
$100.01 to $150.00 $16.95 
$150.01 to $200.00 $19.95 
Over $200.00 $22.95 

5. For amounts over $200, select over 200 → Edit. Enter $22.95 and click 
Accept. 

6. Click the Save and Back to Shipping Methods List icon. 
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Publish Your Catalog to Your Site 
The catalog will not be available until it is published. This is done in the Catalog 
Editor. 

1. Select Catalogs → Catalog Editor. 
2. Click Books in the Catalog window. 

3. Click the Update Catalog icon. 
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Accessing the Retail Website 
After you have completed the previous steps, you are ready to test the Retail site to 
ensure that e-commerce storefront has been configured properly. Ask your 
neighbor to browse to your web server, and you should browse to your neighbor’s 
web server. 

1. From your web browser computer go to http://ipaddress/Retail, where 
ipaddress is address of your web server. 

2. Click New user and enter your information. 

3. Go to the Products page. 

4. Select several items to purchase. 

5. Select a shipping method and check out. 
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Running Reports 
Commerce Server 2000 provides approximately 50 default reports. You can run 
both dynamic and static reports from the Reports module or you can schedule 
reports to be run automatically on a regular basis. Dynamic reports run in a matter 
of seconds and display in a separate window in a table format. 

In this exercise, you will run a dynamic report displaying an executive summary of 
daily site usage. 

1. Click Analysis → Reports. 

2. In the Reports window, click  on the toolbar. 
3. In the Find window, click the Find by drop-down list and select Name. 

4. In the Name field enter Usage Summary. 

5. Click the Find Now button. 

6. In the Find window, select the Usage Summary by Day of Week report, and 
click  on the toolbar to run the report. 

7. The report displays in a new window. 

8. You can save the report for future reference by clicking Save Report. 
9. In the Report Name field, enter Daily Usage Summary, and click OK. 

10. Close the browser window. 
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Deploying Content Management Server  
Lab 4 

Objectives 
After completing this lab, you should be able to: 

! Install Microsoft Content Management Server. 

! Install Content Management Server Site Builder. 

! Install the Content Management Server Service Pack. 

! Install the sample site. 

! Testing the website. 

! Install Site Stager. 

Requirements 
! SQL Server 7 or SQL Server 2000 

! SQL Server Service Pack 2 or higher, which includes: 

• ADSI 2.5 or higher 

• MDAC 2.5 or higher 
! Internet Explorer 5 or higher 

! Microsoft Java VM 

! Microsoft IIS 5 

 

 



Compaq Internet Security and E-Commerce Solutions 

L4 – 2 2.41 

Installing Content Management Server 
Content Management Server is installed in three phases. The installation program 
itself includes only the steps for installing files and setting up registry key 
information. The Database Configuration Application (DCA) and the Server 
Configuration Application (SCA) carry out the remaining functions. 

To install Content Management Server: 

1. Run the setup program from the directory provided by the instructor. The 
Commerce Server 2000 Setup program starts. 

2. Click Install Components. 

3. Click Install Server. 

4. The Welcome dialog box displays. Click Next to start the Installation wizard. 

5. The License Agreement dialog box displays. Select I accept the terms in the 
license agreement and click Next. 

6. The 3rd Party Software Requirements dialog box verifies that the 
prerequisites have been met for the Content Management Server installation. 
Each third-party component must have a status of Pass. Click Next if the 
requirements are met. 

7. In the Customer Information dialog box, type the 25-character product key 
provided by the instructor, and then click Next. 

8. In the Destination Folder dialog box, accept the default installation folder. 
Click Next. 

9. In the Disk Cache Folder dialog box, accept the default folder. Accept the 
default cache size or enter a value of at least 50. Click Next. 

10. Click Install in the Ready to Install the Program dialog box. 

11. Click Finish when the installation is complete. 
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Installing the Database 

  
1. After the Database Configuration Application launches, click Next. 

 
 

2. Select the IIS website that will serve as the entry point for Content 
Management Server. Click Next. 
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3. Select the IIS website that will serve as the entry point for the SCA. Click 
Next. 

 
 

4. Click Browse and select the domain Administrator as the username for the 
Content Management Server System Account. Click OK and enter a 
password. Click Next.  

5. Ensure that the account entered has the necessary rights to the database by 
selecting Yes if the dialog box displays confirming whether to grant the right. 

6. If IIS is running on the server, a dialog box notifies you that the IIS service 
will be stopped. Click Yes to stop the service. 

7. Click Next to select SQL Server 7/2000 as the database platform. 
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8. Select the server name from the drop-down list and click the Options button. 
Select the master database and English as the language. Click OK. 

9. Click Yes in the dialog box to install into an empty database. 

10. Confirm that the SQL Server name and Database name fields contain the 
correct information. Click Next to populate the database with initial schema 
and data. 
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11. Enter the domain and user information. Initially, this will be the only account 

that can log on to Content Management Server. Use this account to set up 
Content Management Server access rights and hierarchies. Enter a password 
and click Next. 

 
 Note 

This is not the same account as the Content Management Server System 
Account. This account is added to the database; the MSCMS 2001 System 
Account is not added. 

 
12. In the MSCMS Site Stager Access Configuration dialog box, select Yes – 

Restrict Access to Local Server Machine and click Next. 
13. The database installation process is complete. Ensure that the option to 

Launch Server Configuration Application now is checked. Click Finish. 
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After completing the database installation, the DCA automatically allows you to 
continue with the Server Configuration Application (SCA). 

 
 

By default, the disk cache directory is installed on the same drive as Microsoft 
Windows. HP recommends either moving the IIS log files from the default 
location in the Windows directory to another drive or moving the disk cache 
directory to another drive. This prevents log files from accumulating and causing 
problems with the ability to cache data. 

To change the cache configuration: 

1. Click Cache → Configure. 
2. Click Browse and select the new location. Click OK. 

3. Enter 100 for the Maximum Disk Cache Size (MB). 

4. Click OK to return to the MSCMS Configuration Application screen. 
 
 Note 

There is a button for clearing the memory cache on the Cache tab. The server 
caches information in memory so that it does not have to go to the database to 
retrieve information that was recently accessed. Use the Clear Memory Cache 
button if the cache is not being synchronized with the database. Performing the 
clear operation has a minor impact on performance. 

 
5. Click Close Application. 
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Installing Content Management Server Site Builder 
Follow these steps to install Content Management Server Site Builder. 

1. Run the setup program from the directory provided by the instructor. The 
Content Management Server 2000 Setup program starts. 

2. Click Install Components. 

3. Click Install Site Builder. 

4. The Welcome screen displays. Click Next to start the Installation wizard. 

5. The 3rd Party Software Requirements dialog box lists the prerequisites for 
the Site Builder installation. Click Next. 

6. In the User Information dialog box, enter your name and click Next. 
7. Click Next to accept the default installation folder in the Choose Destination 

Location dialog box. 

8. In the Select Program Folder dialog box, accept the default program folder. 
Click Next. 

9. Enter the name of the server in which Content Management Server is 
installed and click Next. 

10. Click Next in the Start Copying Files dialog box. 

11. Select Yes, I want to restart my computer now and click Finish to complete 
the setup wizard. 
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Installing Content Management Server Service Pack 
Content Management Server Service Pack contains the latest updates and fixes. 
Follow these steps to install the service pack. 

1. Run CMS2001SP1.EXE from the classroom folder. 

2. Enter c:\ as the location to extract the files and click Unzip. After the files 
have been extracted click Close. 

3. Run C:\CMSSP1\CMS2001_SP1_Install.exe. 

4. The Welcome dialog box displays. Click Next to start the Setup wizard. 

5. The License Agreement dialog box displays. Select I accept the terms in the 
license agreement and click Next. 

6. Server and Site Builder should be listed in the dialog box as components that 
will be updated. Click Next. 

7. Click Install to begin the installation. 

8. Click Finish to complete the Setup wizard. 

There is no need to restart the web server. 
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Installing a Sample Website 
The sample website provided for this lab features best practices for building a 
Microsoft Content Management Server website. It includes sample code for 
navigation and page templates, as well as sample project plans and technical 
specifications. 

1. Run the setup program from the directory provided by the instructor. The 
Content Management Server 2000 Setup program starts. 

2. Click Install Components. 

3. Click Install Sample Data. 

4. The Welcome dialog box displays. Click Next to start the Setup wizard. 

5. The Pre-requisite Check dialog box lists the prerequisites for the MSCMS 
Sample Data installation. Click Next. 

6. Select Yes, I would like to install to import the sample data. Click Next. 
7. Enter <domain>\Administrator as the User Name and enter the 

Administrator password. Click Next. 
8. Click Install to begin the installation. 

9. To complete the installation, click Finish.  
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Accessing the Site 
Site Builder is used to create the site structure and assign user roles and 
responsibilities. The structure of the sample website, Method Systems, is already 
in place. However, roles and responsibilities must be assigned. 

Creating Users 
Create the users who will fulfill the roles used by MSCMS. 

1. Select Start → Programs → Administrative Tools → Active Directory Users 
and Computers. 

2. Right-click Users and select New → User. 
3. Create the following users. 
 

First name Last name User logon name 
Designer 1 Designer1 
Author 1 Author1 
Editor 1 Editor1 
Moderator 1 Moderator1 

 
4. Close the Active Directory Users and Computers windows. 

Creating Rights Groups 
To define the appropriate user roles, you must first create the associated rights 
groups. 

1. Select Start → Programs → Microsoft Content Management Server → Site 
Builder. 

2. Select Login as Administrator and click Start. 

3. Click User Roles → Administrator in the User roles pane. 

4. Select File → New → Rights Group. The group name New Rights Group 
displays in the Administrators pane. 

5. Rename the group Administrators Group. 

6. Repeat steps 3 through 5 for the Subscriber, Author, Editor, Moderator, 
Resource Manager, and Template Designer user roles. 
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Defining User Roles 
Site Builder is used to define the roles of the users you created in Active Directory. 

1. Click Administrators in the User roles pane. 

2. Right-click Administrator in the Administrators pane and select Properties. 

3. Select the Group Members tab and click Modify. 

4. In the NT Domains pane, click the domain folder that is shown and select 
Select from list of all groups and users. 

5. Select Moderator and click Add. 

6. Click OK → OK. 
7. Repeat steps 1 through 6 to add the Guest user to the Subscribers group and 

Author, Editor, Moderator, and Designer to the associated MSCMS user 
groups. 

 



Deploying Content Management Server 

2.41 L4 – 13 

Enabling Site Access 
The website will not be available until Guest access is enabled. This is done in the 
SCA. 

1. Run the SCA. Select Start → Programs → Microsoft Content Management 
Server → Server Configuration Application. 

2. Click the Security tab, then the Configure button. 

3. Select Yes to allow guests on the site. 

4. Click Browse next to the Guest Login Account field. 

5. Click OK to continue browsing Active Directory. 

6. Select the name of your group domain from the NT Domain field. 

7. Select the Guest account and click OK → OK. 

8. Click Close Application → Yes to exit the SCA. 

Enabling the Channel for the Web Author 
The following steps are required to make the channel available on the Web 
Author. 

1. On the Web Authoring tab, select Enable Web Author Access on this 
Channel. 

2. In the Folder field, browse to select a folder. Pages using the Web Author are 
generated in this folder. If a suitable folder does not exist, you need to create 
one, then return to this screen to assign the folder. To allow authoring on this 
channel, a folder must be associated with it. 

3. In the Template Gallery box, browse to select the template gallery that stores 
Web Author templates. The template gallery you choose will be available to 
authors when they create pages for the Web Author. 

The following steps outline a simple publishing cycle in the Web Author to 
illustrate the publishing process from the perspective of authors, editors, and 
moderators. 

To create a page: 

1. Launch Internet Explorer and enter the URL of the Method Systems Intranet 
website. 

2. Log on as Author1. 

3. Click Switch to Edit Site. 

You can tell what a placeholder allows by which icons are present in the upper 
right-hand corner of a placeholder. 
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Running Reports 
You can run a report on pages, resources, and template objects. The reports are 
based on those objects and their use. To run a report: 

1. Select Start → Programs → Microsoft Content Management Server → Site 
Builder. 

2. Click Folders to navigate the Method Systems folder hierarchy. 

3. Click Extranet → Customer Service to view the contents of the folder. 

4. In the Customer Service pane, right-click Bulletin 2347 and select Resource 
Report. 
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Testing the Website 
After you have completed the previous steps, you are ready to test the Method 
Systems site to ensure that the site has been configured properly. Ask your 
neighbor to browse to your web server, and you should browse to your neighbor’s 
web server. 

1. From your web browser computer go to http://ipaddress/Method+Systems, 
where ipaddress is address of your web server. 

2. Click each topic to navigate the site. 
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Installing Site Stager 
Site Stager is an optional MSCMS component that allows you to convert website 
content to HTML files that can be copied to another server regardless of the 
platform. To install Site Stager: 

1. Run the setup program from the directory provided by the instructor. The 
Commerce Server 2000 Setup program starts. 

2. Click Install Components. 

3. Click Install Site Stager. 

4. The Welcome dialog box displays. Click Next to start the Installation wizard. 

5. The Site Stager Install Prerequisites dialog box lists the prerequisites for the 
installation. Click Next. 

6. In the Choose Destination Location dialog box, accept the default installation 
folder. Click Next. 

7. In the Select Program Folder dialog box, accept the default program folder. 
Click Next. 

8. In the Destination User Account dialog box, click Browse. Select an AD user 
account that provides the security context under which Site Stager downloads 
and creates files and directors, and click OK. Click Next to continue. 

9. Accept the default Site Map URL and click Next. 
10. Select Yes, I want to restart my computer now and click Finish to complete 

the Setup wizard. 
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Network Load Balancing  
Lab 5 

Objective 
After completing this lab, you should be able to: 

! Install and configure the Web Application Stress Tool. 

! Install and configure Microsoft Network Load Balancing (NLB). 

! Manage a load-balanced server array. 

Requirements 
! Retail website installed and configured in Module 3 Lab 

! Microsoft Web Application Stress tool 
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Install the Microsoft Web Application Stress Tool 
The Microsoft Web Application Stress (WAS) tool is a simulation tool developed 
to realistically reproduce multiple browsers requesting pages from a web 
application. 

To install the WAS tool: 

1. Run wastsetup.exe from the class folder. 

2. The Software License Agreement screen displays. Click Yes to accept the 
terms. 

3. Click Next on the Select Destination screen to accept the default location for 
program files. 

4. After the installation is complete, click OK → Finish. 
5. Use Windows Explorer to copy the Samples folder to the root directory of the 

Retail website folder (inetpub\wwwroot\retail). 
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Configuring the WAS Tool 
After installing and opening WAS for the first time, a script is created called 
Sample Script. Review this script to become familiar with some of the features in 
the WAS tool. 

1. Select Start → Programs → Microsoft Web Application Stress Tool → 
Microsoft Web Application Stress Tool. 

2. Close the Create new script dialog box. 

3. The left pane of the main WAS window is known as the script view. This 
view displays all of the scripts stored in the current WAS database. The 
Defaults and Sample Script are displayed in the script view. 

4. Expand and click Sample Script. There are seven script items in the Sample 
Script. Each script item uses a special feature of WAS. 

 
5. The Verb value of one of the script items shown in the right window is POST. 

Highlight the row header to the left of the POST script item, then double-
click. This opens the script item details view. From this view you can edit the 
querystring name-value pairs, change POST data, modify the header, and 
enable SSL. 

6. Click OK to close the script item details view. 
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7. Select Perf Counters from the script tree and click Add counter. It may take a 
moment to load the Add Counters dialog when this button is clicked for the 
first time. Add the following counters:  

• Web Service: Get Requests/sec  

• Web Service: Post Requests/sec  

• System: % Total processor time  

• Active Server Pages: Requests/sec  

 
 

8. Change the Collection Interval to every 5 seconds. Capturing the correct 
performance monitor counters is critical to obtaining the correct data to 
analyze when the test completes. 
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9. Select Settings and view the settings that can be configured for a script. You 
may also set the default settings for all new scripts by selecting the Defaults 
node and changing those options. Keep in mind that the settings in the 
Defaults node will not affect existing scripts, such as the Sample Script. 

10. Click Sample Script and select Scripts → Run. Allow the test to complete. 
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11. Select View → Reports to open the Reports view. Expand the Sample Script 
report to display all of the report nodes. There should be at least one node 
titled with the date and time in which your latest test was started. Expand and 
select the top level of this report node to view a summary of this test. 
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Installing and Configuring Network Load Balancing 
To install NLB: 

1. Select Start → Settings → Control Panel and double-click Network and Dial-
up Connections. 

 
2. Right-click the Local Area Connection on which Network Load Balancing is 

to be installed, and click Properties. The Local Area Connection Properties 
dialog box displays.  

3. Under Components checked are used by this connection, select Network Load 
Balancing. 

4. Click Properties. Select the Cluster Parameters tab in the Network Load 
Balancing Properties dialog box.  

5. In the Primary IP address field enter the IP address assigned to the Retail site 
in IIS. 

6. Enter the associated subnet mask for the IP address in the Subnet mask field. 

7. Select Multicast support. 
8. Click the Host tab and enter the dedicated IP address. 

9. Enter the associated subnet mask for the IP address in the Subnet mask field. 

10. Click Advanced, and then click Add.  

11. Enter the server array IP address in the space for IP address, followed by the 
appropriate subnet mask. This IP address corresponds to the Primary IP 
address of the server array that you entered in the Network Load Balancing 
Properties dialog box under Cluster parameters. 

12. After you have finished, click OK → OK to return to the Local Area 
Connection Status dialog box. 

13. Right-click the Local Area Connection on which Network Load Balancing is 
to be installed, and click Properties.  

14. Click Internet Protocol (TCP/IP), and then click Properties.  

15. Set up TCP/IP for Network Load Balancing. 

16. Repeat these steps on each host to be used in your Network Load Balancing 
server array.  

These settings are recorded in the registry and the changes are applied when you 
click OK in the Network Load Balancing Properties dialog box. Clicking OK stops 
Network Load Balancing (if it is running), reloads the parameters, and then restarts 
cluster operations.  
 
 



HP Internet Security and E-Commerce Solutions 

L5 – 8 Rev. 2.41 

NLB Administration 
To stop Network Load Balancing: 

1. Select Start → Programs → Accessories → Command Prompt. 

2. At the command prompt, enter wlbs stop. Load balancing operations are 
immediately stopped on the local server array host. 

To stop cluster operations on all cluster hosts, type wlbs stop followed by the 
server array IP address or server array name. 
 
 Note 

When you use wlbs stop, any client connections already in progress are 
interrupted. To avoid interrupting active connections, consider using the 
drainstop cluster control command. 

 
You can restart cluster operations on the local cluster host by either restarting the 
computer or entering wlbs start at the command prompt. Similarly, you can 
restart cluster operations on all cluster hosts by entering wlbs start followed by 
the server array IP address or server array name. 
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Web Server Management  
Module 6 Lab 

Objectives 
After completing this lab, you should be able to: 

! Optimize memory usage. 

! Optimize network bandwidth. 

! Monitor web server performance using System Monitor. 
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Optimizing Memory Usage 
Servers are generally configured to give preference to the File System Cache over 
the working sets of processes when allocating memory space. The setting 
Maximize Throughput for File Sharing often causes the IIS pageable code to be 
written to disk, which results in lengthy processing delays. To avoid these 
processing delays, modify the server properties to the maximize data throughput 
for network applications.  

To change server properties: 

1. On the desktop, double-click My Computer and select Network and Dial-up 
Connections.  

2. Right-click Local Area Connection and select Properties.  

3. Select File and Printer Sharing for Microsoft Networks → Properties.  
4. On the Server Optimization property tab, select Maximize data throughput 

for network applications.  

Concurrent Connections 
To control the number of concurrent connections:  

1. Click Start → Programs → Administrative Tools → Internet Services 
Manager. 

2. Right-click the Retail site, click Properties, and select the Web Site tab.  

3. Select Limited To in the Connections panel. Enter the maximum number of 
connections you want to allow. 
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Optimizing Network Bandwidth 
To ensure optimal bandwidth, you can also verify that HTTP Keep-Alives are 
enabled. To verify the state: 

1. Click Start → Programs → Administrative Tools → Internet Services 
Manager. 

2. Right-click the website and select Properties. 
3. Select the Performance tab and verify that the HTTP Keep-Alives Enabled 

option is checked. 
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Performance Monitoring 
You begin monitoring your sites by planning for capacity and by configuring your 
monitoring tools to keep monitoring overhead low. You should create monitoring 
configurations that can be saved and copied to other computers using the System 
Monitor in the Microsoft Management Console (MMC). A monitoring 
configuration will help you highlight data center issues and visualize traffic flow 
through your system. Creating this configuration can also help you to understand 
any site software issues and to see how the software is interrelated. 

System Monitor 
System Monitor measures the performance of the computer on which it is installed 
or other computers on a network. System Monitor uses a series of counters that 
track data, such as the number of processes waiting for disk time, the number of 
network packets transmitted per second, and the percentage of processor 
utilization. With this data, you can create charts, set alerts, and format reports that 
enable you to gauge and tune system performance. Data can be displayed as it is 
collected, stored in log files for later use and comparison, or both. 

To set a performance counter: 

1. Click Start, → Programs, → Microsoft Commerce Server, and then click 
Commerce Server Manager. 

2. Click System Monitor to open the performance console.  

3. In the performance console, click the plus sign (+) on the System Monitor 
toolbar to add performance counters to your server. 

4. In the Add Counters dialog box, select the ASP counters listed in the Student 
Guide. 

5. Click Add to add all counters you have selected, and then click Close. 

6. Run the Sample Script of the WAS tool. Compare the reports of other 
students. 

  



 

2.41 L7 – 1 

Evaluating Security Vulnerabilities 
Module 7 Lab 

Objectives 
After completing this lab, you should be able to: 

! Install IIS Lockdown tool. 

! Install Microsoft URLScan security tool. 

! Install Internet Scanner. 

! Correct network vulnerabilities. 

Requirements 
! IIS Lockdown version 2.0 or later 

! URLScan version 2.0 or later 

! Internet Scanner version 6.2.1 
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Installing IIS Lockdown 
IIS Lockdown Wizard turns off unnecessary features, which reduces the options 
available to attackers. To provide multiple layers of protection against attackers, 
URLscan, with customized templates for each supported server role, is integrated 
into the IIS Lockdown wizard. 

On the web server: 

1. Run iislockd.exe to start the Internet Information Services Lockdown 
Wizard. 

2. Click Next. 
3. Select I agree and click Next. 
4. In the Select Server Template window, select the Commerce Server 2000 

template. Click Next. 
5. Ensure that the Install URLScan filter on the server check box is selected and 

click Next. 
6. Review the changes that will be made to IIS configuration of the web server 

on the Ready to Apply Settings screen. Click Next. 
7. The security settings lists in the Status pane of the Applying Security Settings 

window are applied. When the process is finished, click the View Report 
button to view the changes in the log. 

8. Close the report log window. Click Next. 
9. Click Finish. 
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Installing URLScan 
The URLScan security tool screens all incoming requests to an IIS web server.  If 
a request does not comply with the rule set created by the administrator, it is 
blocked. Blocking specific HTTP requests prevents potentially harmful requests 
from reaching the server and causing damage. 

The URLScan security tool is comprised of two files: Urlscan.dll and Urlscan.ini, 
and these files are packaged together in Urlscan.exe. The instructor will inform 
you of the location of the urlscan.exe file. 

On your client computer: 

1. Create a new folder on the C:\ root directory with the name lockdown_files. 

2. Open a command prompt window. 

3. Locate the directory of the IIS Lockdown Wizard specified by your 
instructor. 

4. Execute the following command to extract the URLscan files. 
iislockd.exe /q /c /t:c:\lockdown_files 

5. Open the IIS snap-in. 

6. Right-click the server name under Internet Information Services in the MMC, 
then select Properties. 

7. Verify that WWW Service is displayed in the Master Properties drop-down 
list, and click Edit. 

8. Choose the ISAPI Filters tab, and then click Add. 

9. In the Filter Properties window, type urlscan, and enter the full path to 
urlscan.dll in the Executable field. 

10. Select OK to close each dialog box. 

11. Restart IIS. 

When properly installed, URLScan will run automatically whenever IIS is started. 
To confirm the operation of URLScan, locate the log file, urlscan.log, in the 
directory that contains urlscan.dll. 
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Installing Internet Scanner 
On the client computer: 

1. Run the executable file, issnt.exe. 

2. Click Next on the Welcome screen. 

3. Review the license agreement and click Yes. 

4. Review the latest features and changes in the What’s New in Internet Scanner 
6.2.1 screen. Click Next. 

5. Click Next to accept the destination folder where Setup will install files. 

6. Review the settings and click Next. Setup will begin copying the program 
files. 

7. Click Finish to restart the computer. 
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Configuring Internet Scanner 
1. Click Start → Programs → ISS → Internet Scanner 6.2.1 → Internet 

Scanner 6.2.1. 

2. A warning dialog box displays indicating that no valid license keys were 
found. Click OK.  

 
 

3. Select Create a New Session → OK. The Select Key dialog box displays 
indicating that no valid keys were detected and that the session will be 
configured to scan only the local host. That is fine for this purposes of this 
lab. Click Next. The Select a Policy dialog box displays. 
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4. Click Next in the Select a Key dialog box. The New Policy Wizard runs. 

 
 

5. Highlight L3 NT Server and click Next. 
6. In the New Session Wizard – Scan Session Information dialog box, add a 

comment such as Lab Scan; then click Finish. 

The ISS Scanner console screen opens and displays the names of the hosts to 
be scanned. 
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Running a Vulnerability Assessment Scan 
In this part of the lab, you will: 

! Scan for vulnerabilities. 

! Analyze the vulnerabilities. 

! Correct the vulnerabilities (optional). 

! Rescan the network to verify that vulnerabilities have been resolved 
(optional). 

To run the scan: 

1. From the ISS console, highlight 127.0.0.1. 

2. Click Scan → Scan Now. The scan will take four to eight minutes to 
complete. 
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Analyzing the Vulnerabilities 
ISS Internet Scanner provides information that helps you analyze and correct the 
vulnerabilities it detects. 

1. When the scan is finished, highlight the IP address for your firewall server. 

2. Click the Vulnerabilities tab. 

3. Expand the listing of vulnerabilities in the upper left pane. 
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4. Right-click a vulnerability and select What’s This? to observe details about 
the detected vulnerability. 

 
 

5. Note the vulnerability and how to fix it. 
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Lab Challenge 
If time permits, complete the following tasks: 

! Correct any vulnerability that was detected on your firewall server. 

! Evaluate the vulnerabilities that were detected on your client server. Choose 
one or two vulnerabilities and take the steps necessary to correct them. 

! Rescan the firewall and client and verify that all vulnerabilities have been 
corrected. 
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Lab Review 
1. How might a security scan affect the performance of your network? 

............................................................................................................................  

............................................................................................................................  

2. When should you run vulnerability assessment scans?  

............................................................................................................................  

............................................................................................................................  

3. Is it possible to eliminate all vulnerabilities in a network? Why or why not? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Implementing Intrusion Detection 
Module 8 Lab 

Objectives 
After completing this lab, you should be able to: 

! Install an ISS RealSecure network sensor. 

! Install a RealSecure server sensor. 

! Install RealSecure Workgroup Manager. 

! Customize an automated installation file to deploy a server sensor on multiple 
servers. 

! Use the RealSecure automated installation feature to install a server sensor. 

! Configure Workgroup Manager to communicate with network and server 
sensors. 

! Test the network sensor and server sensors. 
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Lab Scenario 

ISS Internet
Scanner

Vulnerability
Assessment Server

Firewall

CLIENT1 CLIENT2SERVER1 SERVER2

ASE.COM Network ASEPRO.COM NetworkSimulated Internet

Firewall

Simulated
Internet

ISS Internet
Scanner

Vulnerability
Assessment Server  

 

You are a network administrator working in either the ASE.COM or the 
ASEPRO.COM network. Your assignment is to complete the following tasks: 

! Install ISS Internet Scanner on your vulnerability assessment server. 

! Scan your network for vulnerabilities. 

! Correct any detected vulnerabilities and rescan. 
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Installing Internet Scanner 
On your client computer: 

1. Run ISSNT.EXE from the location specified by your instructor. 

2. When the Welcome screen displays, select Continue.  

3. A dialog box will display indicating that ISS Internet Scanner 6.1 is not 
supported on NT Server. For the purposes of this lab, click Yes to proceed. 

4. In the Welcome screen, click Next. 
5. Select Yes to accept the User License Agreement. 
6. Select Next to accept the destination directory. 

7. Select Next in the Choose Destination dialog box. The files will be copied to 
the destination directory. 

8. A question dialog box will display asking if you want ISS to modify some 
parameters to optimize performance. Answer No on this dialog box. 

9. Click OK in the Setup Complete dialog box. 

10. Click OK in the Information dialog box. 

11. Click No when asked if you want to view the README file. 

12. Click OK to restart the computer. 



Compaq Internet Security and e-Commerce Solutions 

L8 – 4 2.41 

Configuring Internet Scanner 
1. Click Start → Programs → ISS → Internet Scanner 6.1 → Internet Scanner 

6.1. 

2. A warning dialog box displays indicating that no valid license keys were 
found. Click OK.  

 
 

3. Select Create a New Session → OK. The Select Key dialog box displays 
indicating that no valid keys were detected and that the session will be 
configured to scan only the local host. That is fine for this purposes of this 
lab. Click Next. The Select a Policy dialog box displays. 
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4. Click Next in the Select a Key dialog box. The New Policy Wizard runs. 

 
 

5. Highlight L3 NT Server and click Next. 
6. In the New Session Wizard - Comment dialog box, add a comment such as 

Lab Scan; then click Finish. 

At this point, the ISS Scanner console screen opens and displays the names of 
the hosts to be scanned. 
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Running a Vulnerability Assessment Scan 
In this part of the lab, you will: 

! Scan for vulnerabilities. 

! Analyze the vulnerabilities. 

! Correct the vulnerabilities (optional). 

! Rescan the network to verify that vulnerabilities have been resolved 
(optional). 

To run the scan: 

1. From the ISS console, highlight 127.0.0.1. 

2. Click Scan → Scan Now. This scan will probably take four to eight minutes 
to complete. 
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Analyzing the Vulnerabilities 
Security Scanner provides information that helps you analyze and correct the 
vulnerabilities it detects. 

1. When the scan is finished, highlight the IP address for your firewall server. 

2. Click the Vulnerabilities tab. 

3. Expand the listing of vulnerabilities in the upper left pane. 
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4. Right-click on a vulnerability and select What’s This? to observe details 
about the detected vulnerabilities. 

 
 

5. Note the vulnerability and how to fix it. 
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Lab Challenge 
If time permits, complete the following tasks: 

! Correct any vulnerabilities that were detected on your firewall server. 

! Evaluate the vulnerabilities that were detected on your client server. Choose 
one or two vulnerabilities and take the steps necessary to correct them. 

! Rescan the firewall and client and verify that all vulnerabilities have been 
corrected. 
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Lab Review 
1. How might a security scan affect the performance of your network? 

............................................................................................................................  

............................................................................................................................  

2. When should you run vulnerability assessment scans?  

............................................................................................................................  

............................................................................................................................  

3. Is it practical to eliminate all vulnerabilities in a network? Why or why not? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Installing a Firewall 
Module 9 Lab 

Objectives 
After completing this lab, you should be able to: 

! Install and configure Microsoft ISA. 

! Control incoming requests using web publishing rules and routing rules for 
ISA server security. 

! Observe how the ISA configuration affects website performance. 
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 Verifying Preliminary Network Configuration 
Before starting this lab, verify the following: 

! Microsoft Windows 2000 is installed. 

! Service Pack 2 (or later) is installed. 

• Click Start → Run, enter WINVER and press Enter to view the service 
pack version. 

! Microsoft Internet Explorer 5.5 (or later) is installed. 

! You have access to the ISA and Enterprise Firewall software. 

! Networking configuration is correct and each machine can ping each 
connected machine. 
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Installing and Configuring Microsoft ISA 
This course uses an evaluation copy of Microsoft ISA. 

1. Run the ISA evaluation file at the command prompt to extract the files to the 
default folder. 

Is2k_ee_eval_rtw.exe 

The main setup menu displays. 

 
 

2. Select Install ISA Server. At the Welcome screen, click Continue. 

3. Enter the product key number provided by the instructor, click OK → OK. 
4. On the License Agreement screen, select I Agree. 

5. For the installation type, select Full Installation. 

6. A dialog box displays indicating the computer cannot join an array. Select 
Yes to install ISA as a stand-alone server. 

7. Select Firewall mode and click Continue. 

8. When warned about the stopping of the IIS service, click OK. 
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9. Enter the IP address range for your student group configuration. 
Example 

 
Group 1 configuration 

From 192.168.1.10 
To 192.168.1.100 

 
Click Add. 

10. The ISA Server uses the local address table (LAT) to differentiate between 
the internal and external networks. Begin by selecting Construct Table. 

11. Select your internal NIC and click OK. 

12. At the Setup Message dialog box, click OK. 

13. Verify the accuracy of the table and click OK. 

14. Select Start ISA Server Getting Started Wizard and click OK. 

15. Click OK on the setup completion dialog box. The ISA Management console 
displays. 

Configure ISA Server 
Before creating rules ISA Server must be configured to listen for incoming web 
requests. The incoming web request properties specify which IP addresses and 
ports on the ISA Server computer listen for incoming web requests. The incoming 
web request properties also determine the necessary authentication required when 
accessing internal servers. 

To configure ports for listening: 

1. In the console tree of ISA Management, expand Servers and Arrays. 

2. Right-click the name of your firewall server and select Properties. 

3. Select the Incoming Web Requests tab.  

4. Click Add. 

5. Select the name of the firewall server from the Server drop-down list. 

6. Select the external IP address of the firewall server 

7. Type the name of the server as the display name. 

8. Click OK → Apply → OK → OK. 

9. Right-click the name of your firewall server and select Disconnect to stop the 
firewall service. 

10. In the Configure Servers and Arrays panel, click Connect To. 

11. Select Connect to this stand-alone server and click OK. 
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Controlling Incoming Requests 
ISA Server allows you to configure rules that determine which requests should be 
sent downstream to a server located behind the ISA Server computer. The ISA 
Server computer impersonates the website because its IP address is the one 
associated with the DNS name of the site. By impersonating the published server 
to the external world, ISA Server offers an additional layer of security. 

Create a Destination Set 
When rules are created, the destinations that are accessible must be specified. 
Destination sets specify the path on the web server that contains the website 
content. 

1. In the ISA Management console expand the firewall server name and Policy 
Elements. 

2. Right-click the Destination Sets folder and select New → Set. 
3. Enter a name and description, and click Add. 

4. For Add/Edit Destination, enter the IP address of the web server. 

5. In the Path field enter Retail as the directory. Click OK → OK. 

Create a Web Publishing Rule 
Web publishing rules determine how ISA Server intercepts incoming requests for 
Hypertext Transfer Protocol (HTTP) objects on an internal web server and how 
ISA Server should respond on behalf of the web server. Requests are forwarded 
downstream to the web server located behind the ISA Server computer. 

To create a web publishing rule: 

1. Expand Publishing. 

2. Click Web Publishing Rules. 

3. In the Publish Web Servers pane, click Create a Web Publishing Rule. 

4. The Welcome to the New Web Publishing Rule Wizard displays. Type a 
name for the web publishing rule and click Next. 

5. In the Destination Sets dialog box, select All internal destinations from the 
drop-down list. Click Next. 

6. In the Client Type dialog box select Any request. Click Next. 
7. In the Rule Action dialog box, select Redirect the request to this internal web 

server (name or IP address). Enter the IP address of the web server and click 
Next. 

8. Click Finish. 

9. Two entries display under Web Publishing Rules. The one named Last is 
installed by default. Its purpose is to deny any access not explicitly granted 
by the administrator. 
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Test the Published Web Server 
1. Go to your client and enter the URL for the web server for another student 

group. Ask another group to access your web server. 

2. On the ISA Server console the new session displays listing the IP address. 
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System Hardening 
To further secure ISA Server, use the built-in System Hardening Wizard. This 
wizard locks down the underlying Windows 2000 operating system by disabling 
services unrelated to ISA Server. 

1. In the ISA Management console expand your firewall server name. Select 
Computer. 

2. Right-click your server in the right pane and select Secure. 

3. The ISA Server Security Configuration Wizard Welcome screen displays. 
Click Next. 

4. In the Select Security Level dialog box, select Dedicated and click Next. 
5. At the Congratulations page, click Finish. 

6. A dialog box displays indicating the security settings process has completed. 
Click OK. 

7. The System Hardening Wizard uses Windows 2000 security features to run 
one of the standard predefined security templates. To examine the templates, 
choose Start → Run, enter: 

mmc /a 

8. Select Console → Add/Remove Snap-in. 

9. Click Add, scroll down the list, and double-click Security Templates. Click 
Close → OK. 

By comparing some of the security objects in a standard template such as basicdc 
to hisecdc (the high-security domain controller policy template), you should 
observe numerous differences, such as enforcement of password policies. 
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ISA Alerts 
The alert service acts as a dispatcher and as an event filter. It is responsible for 
trapping events, checking whether certain conditions are met, and executing 
corresponding actions. To view the full list of events ISA Server tracks: 

1. In the ISA Management console expand the firewall name then Monitoring 
Configuration. Select the Alerts folder. 

2. Double-click the IP packet dropped alert. 

3. A red dot by the icon indicates the alert is disabled. On the General tab, select 
Enable. 

4. Click the Events tab. To make it easier to see the alert in action, change 
Number of occurrences before the alert is issued to one. 

5. Click the Actions tab. When triggered, an alert can send out e-mail 
notification, execute any program, or start and stop a service. Leave the 
default Report to Windows 2000 event log selected, and click OK. 

6. To test the alert, run the following command from the command line: 
NET USE \\<ISAservername>\<administrativeshare> 

The administrative share is normally C$, C being the installation drive, so the 
command for the test machine would be: 

NET USE \\FIREWALLn\C$ 

7. Select Start → Programs → Administrative Tools → Event Viewer to view 
the Application Log. You will find one or more warnings in the log. 
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Observing the Effects of the Installation 
During installation, ISA hardened the operating system by disabling nonessential 
services. 

To observe the changes that ISA made to the operating system, complete the 
following steps: 

1. Select Control Panel → Services to open the Services dialog box on your 
firewall server. 

2. Which service did ISA add? What is its status? 

............................................................................................................................  

............................................................................................................................  

3. Select Control Panel → Services to open the Services dialog box on a server 
that does not have ISA installed. 

4. Compare the services that are running on the two computers. List the services 
that ISA disabled during installation. 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

5. On your firewall server, open Control Panel → Devices. Did ISA disable any 
HP devices? If so, which ones? 

............................................................................................................................  

............................................................................................................................  

6. On your firewall server, open Control Panel → Network → Protocols. What 
change did ISA make? 

............................................................................................................................  

............................................................................................................................  
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Installing and Using 
Trend Micro Products 

Module 10 Lab  

Objectives 
After completing this lab, you should be able to: 

! Install and configure Trend Micro ServerProtect. 

! Install and configure Trend Micro Interscan WebProtect. 

! Install and configure Trend Micro Virus Control System. 

Requirements 
! Microsoft ISA Server 2000 
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Lab Scenario 
 

 

You are a network administrator working in the Method Systems or Retail 
network. Your assignment is to complete the following tasks: 

! Install and configure an information server and a normal server using Trend 
Micro ServerProtect. 

! Install and configure Trend Micro WebProtect. 

! Install and configure Trend Micro Virus Control System. 
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Trend Micro ServerProtect 
In this part of the lab, you will: 

! Install ServerProtect on your firewall computer. 

! Configure ServerProtect options. 

! Run a manual scan on your client. 

Key Concepts 
ServerProtect facilitates management of network-wide configuration and 
administration by using a domain structure. 

ServerProtect domains are simply a grouping of Windows NT servers running 
ServerProtect. These domains are configured much like Windows NT domains, 
but should not be confused with them. ServerProtect does not use the Windows 
NT domain structure. Therefore, it is necessary to create a ServerProtect domain 
when you install the software. 

ServerProtect domains are grouped under assigned information servers to facilitate 
management of domain configuration. 

In this lab, you will configure your server as an information server and assign a 
domain name. However, you will not add domains or assign other servers to join 
the domain. 
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Installing Server Protect 
On your firewall computer run the Server Protect setup program. 

1. Extract the Server Protect files from sp535_nt.zip into the 
c:\temp\sp535_nt folder. 

2. Execute the Server Protect setup program. 
C:\temp\sp535_nt\setup.exe 

3. Click Next on the Welcome screen 

4. Click Yes to accept the Software License Agreement. Setup checks the boot 
sector of the firewall server for viruses. 

5. Click Yes to continue the Setup. 

6. Setup then asks you to provide user information, including the serial number 
of the software. This lab uses a 30-day trial version so leave the field blank. 
Click Next to continue the setup. 

7. The Select Components screen displays. Select the following check boxes. 

• Install server as a ServerProtect Information  Server 

• Install server as a ServerProtect Normal Server 

• Install Management Console to local machine 
 
 Note 

Do not change the target installation folder. Install all components in the same 
directory. 

 
Click Next. 

8. Select Personal program folder so that only the Administrator can view the 
ServerProtect program from the Windows Start menu. Click OK. 

9. Double-click the target server and accept the default installation path for 
installing ServerProtect Information Server files. Click OK. 

10. Enter the password, Hp_training and a virtual domain name that matches 
your student set such as GROUP1. A password and virtual domain name 
prevents unauthorized access to the Information Server from either the 
Management Console or the setup program. Click Next. 

11. The Start Copying Files dialog box displays. Check the information shown. If 
it is correct, click OK to continue the setup program; otherwise, click Back to 
modify the information. ServerProtect now starts copying all program 
components and starts all services. 

12. After all program components have been copied, the setup program displays 
the Setup Complete screen. Select the I want to view the README file and 
the Launch ServerProtect Management Console check boxes. Click Finish to 
close the setup program. 
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13. The Select an Information Server dialog box displays. To ensure that the 
server list is current, click Refresh. 

14. Select the host name of the firewall server from the list. This is the 
information server that the Management Console will control. If the host 
name of the firewall server does not display, enter either the host name or the 
IP address. 

15. Click OK to save your changes. 
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1. The Configure ServerProtect dialog box displays. 

 
 

The Configure ServerProtect window lets you specify the default 
configuration of the server. As you click on an option, information about that 
option displays on the right side of the dialog box. 

2. In the Action To Take field, select Move as the action to perform if a virus is 
detected. 

3. In the Real-Time Scan Direction dialog box, select Incoming/Outgoing; then 
click Next. The ServerProtect files are copied. 

4. In the Select Service Account dialog box, select Default System Account → 
OK. 

5. In the Setup Complete screen, deselect the View Readme File option; then 
click Finish. 



Installing and Using Trend Micro Products 

Rev. 2.41 L10 – 7 

Configuring ServerProtect 
During installation, you created a domain and established an information server.  

To run ServerProtect, click Start → Programs → ServerProtect → ServerProtect. 
The ServerProtect console displays. 

 
 

To configure ServerProtect: 

1. Highlight your ServerProtect computer in the left pane. 

2. Click Domain → Unlock. 

3. Enter the password vprotect. 
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4. Click Configure and select one of the scan options. 

 
 

5. Click through each of the tabs and observe the configuration options that are 
available for each scan type. 

6. Click OK → Close when finished. 
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Running a Scan 
To run a manual scan on the computer: 

1. Click Do → Manual Scan. The Manual Scan Monitor screen displays. 

 
 

2. Click Scan. The scan will initiate. 

 
 

3. Click OK when the Scanning Complete dialog box displays. 
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Installing Interscan WebProtect 
On your firewall computer run the WebProtect setup program. 

1. Extract the WebProtect files from iswp30.zip into the c:\temp\iswp folder. 

2. Execute the WebProtect setup program 
C:\temp\iswp\setup.exe 

3. Click Next on the Welcome screen 

4. Click Yes to accept the Software License Agreement. 

5. From the User Information screen, enter your name, company's name and 
serial number. Leave the serial number line blank to install the 30-day trial 
version. Click Next to continue. 

6. You will be prompted to Choose Destination Location screen for the program 
files. The default is the WebProtect folder. Click Next to install the program 
files in the c:\Program File\Trend\InterScan\WebProtect directory. 

7. The Select Program Folder window displays. Here you can add the InterScan 
WebProtect for Microsoft ISA Program Group folder. Click Next to use the 
default folder. 

8. You will be prompted to the WebProtect Configuration IP Address and IIS 
Port screen. Provide the correct IP address of your system and the IIS Port 
number (80 is the default IIS port number). Click Next. 

9. You will be prompted to restart IIS before you can run the Trend InterScan 
WebProtect Configuration. Click Yes to restart now and begin configuring the 
program. 

10. When you are prompted to restart the Web Proxy, click Yes. 

11. Click Finish on the Setup Complete screen to finish the installation. 
 
 Note 

The ISA Application filter, HTTP redirector, should be activated on the ISA 
Server so that the FireWall can redirect all http requests to the Web proxy to 
make sure all traffic will pass through InterScan WebProtect. 
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Configuring Interscan WebProtect 
All configuration tasks are accessed the from InterScan WebProtect main window, 
which you can access from web browser. 

To display the main window: 

1. Either select Start → Programs → InterScan WebProtect for ISA → 
WebProtect Configuration or enter the following WebProtect URL in a web 
browser: 

http://IPaddress:port/dir/cgi-bin/webprotect.htm 

where IP address is the IP address of the firewall server, port is the IIS 
running port number and dir is the directory in which InterScan WebProtect 
for ISA Server is installed. 
Example 
http://127.0.0.1:8888/WebProtect/cgi-bin/webprotect.htm 

2. If password security has been set up, the Authentication window will display. 
Type the user name and password and click OK. 

The URL link to web configuration will not work if one of the following 
conditions occurs: 

• The user used a wrong IP address during the program installation. 

• The IP address of the computer was changed after installing InterScan 
WebProtect for ISA. 

• The IIS running port number on the computer was changed. 
To resolve this problem: 

1. Open Windows Explorer and locate the file, /WebProtect/webprot.url. 

2. Right-click webprot.url and select Properties. 

3. In the Web Document tab enter the correct IP address and IIS port 
number in the URL text box; then click Apply → OK. 
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Configuring Notification Options 
To create alerts that indicate the presence of infected files: 

1. From the main menu select Scan Configuration → Notification. 
2. In the Message properties field, enter the email address of the sender and 

subject. 

3. Under Notification, check Notify the following and enter the user name of the 
recipients using a comma to separate multiple entries. 

4. Type the contents of the message in the Message Text field. 
Example 
InterScan WebProtect for ISA has found a virus/malicious code in HTTP 
traffic. 

5. Under Notification Server, enter the hostname (or IP address) and SMTP Port 
number information. 

6. Click Save to apply your changes. 

Selecting Action on Viruses 
InterScan WebProtect can be configured to clean, quarantine, delete, or pass a file 
when a virus is detected. 

To configure the Action on Viruses function of InterScan WebProtect: 

1. From the main menu click Scan Configuration → Virus Action. 
2. Specify Clean as the action for WebProtect to take when it detects an infected 

file. This removes the virus code from infected files and delivers the files to 
the recipient. 

Viewing the Server Log 
InterScan WebProtect maintains a server log, which keeps a record of the date and 
exact time for the following program events: 

! Virus Pattern File updates 

! Virus Pattern File loading 

! InterScan WebProtect startup 

! InterScan WebProtect shutdown 

To view the server log: 

1. From the main menu select Log → View Server Log. 

2. From the View Server Log screen, select View all dates, to see all the logs 
available 
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Deleting Log Files 
Because InterScan WebProtect creates and saves new log data daily, accumulating 
data may eventually consume a lot of disk space. If some log files are no longer 
needed, delete them manually or automatically. 

Deleting Log Files Manually 
1. From the main menu select Log → Delete Log. The Log Maintenance 

window displays. 

2. Under Delete Logs, select All logs. 

4. To clear log files for selected dates only, click Specific logs. Next, in the 
scrollable list, highlight the log file(s) to delete (click the entries, while holding the 
Ctrl key to multiple select). 

5. Click Delete to proceed with the deletion. If you change your mind, restore the 
previous settings by clicking Restore. 

The program will display a message on the screen to verify that the log files were 
removed. 

Note: Please note that the deleted files will be listed in the Delete Log window 
until you refresh it. 

Deleting Log Files Automatically 
Instead of deleting old log files manually, you can set WebProtect to do it at 
regular intervals. This feature is especially useful if your system handles a large 
volume of file traffic. 

To enable automatic log file deletion: 

1. Go to the main menu and select Log > Schedule Delete. The Configure 
Autodelete window displays. 

Check Enable Autodelete. 

In the text box, enter the number of days you want to retain log files before 
deleting them. If you enter one (1) in this field, the program will save logs for the 
current day and the day before. The maximum number of days you can enter is 90. 

3. Click Save to save your settings and enable automatic log file deletions. 
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Trend Micro Virus Control System 
Trend Virus Control System (VCS) is installed first on a Windows NT server. In a 
separate installation, agents are deployed to other servers running antivirus 
programs. The computers that receive the agents act as clients to the Trend VCS 
server. Each group of Trend VCS agents and the server they are registered to 
constitute a Trend VCS domain. 

Key features of VCS include: 

! All Trend products on the network can be configured from the VCS console. 

! Virus pattern file updates and program upgrades can be centrally deployed. 

! VCS maintains a virus log of virus events for the entire network. 

! Users can perform on-demand scans of diskettes, hard drives, and network 
drives using the HouseCall feature of VCS. 

Communication between the VCS server and VCS agents occurs using a secure 
HTTP technology. Trend VCS is published by the WWW service of Microsoft IIS 
installed on the VCS server. 
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Installing the VCS Server 
The Trend VCS server installs on a Windows NT computer. This component 
provides the user interface (console). 

In this lab, you will install Trend VCS on your client computer. This computer 
has Microsoft IIS installed, which is a prerequisite for Trend VCS. 

To install Trend VCS: 

1. Run tvcsserversetup.exe from the Trend CD or from another directory 
specified by the instructor. If you run this program from the CD, it is located 
in the programs\tvcs\english directory. 

2. Trend VCS will prompt you to approve a change in permissions for 
interactive and network users. Click Yes. 

3. In the Welcome screen, click Next. 
4. In the Software License Agreement screen, click Yes. 

5. In the Enter User Information screen, enter your name and company. If the 
instructor has provided a serial number, enter it. Otherwise, leave the field 
blank to install the 30-day trial version. Click Next. 

6. In the Select Database screen, select the Built-in Database option and then 
click Next. 

7. In the Trend VCS Password screen, enter and confirm a password, and then 
click Next. 

8. The Proxy Information for Pattern Update screen enables you to specify a 
proxy server to access the Internet. For this lab, click Next to bypass this step. 

9. Click Next to accept the file destination. 

10. Click Next to accept the default folder. Files will be copied. 

During the installation, the WWW Publishing Service will be stopped and 
restarted. 
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Running Trend VCS 
To run the Trend VCS console: 

1. Click Start → Programs → Trend Virus Control System → Trend VCS 
Console. Internet Explorer will launch and the Trend login screen will 
display. 

 
 Note 

Trend VCS can also be managed through MMC. 
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2. Enter the password and click the Click here link. The TVCS console displays. 

 
 

From this screen, you can manage the antivirus products running on the 
network. 
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Installing the VCS Agents 
Your firewall server has Trend ServerProtect installed. You can configure the 
Trend VCS console to manage ServerProtect by installing agents on your firewall 
server. 

An agent is a component of Trend VCS that allows the existing server-based 
antivirus programs to communicate with Trend VCS. 

To install the agents: 

1. From the computer running ServerProtect (Server1 or Server2), run 
TvcsAgentSetup.exe from the CD or from a location provided by the 
instructor. If you are running from the CD, this program is found in 
programs\tvcs\english. 

2. In the Trend VCS Agent Setup Welcome screen, click Next. 
3. Click Yes in the License screen. 

4. In the Select Anti-Virus Product screen, select the option for Anti-virus 
products running on Windows NT; then click Next. 

5. The installation program will scan for servers. Double-click the Workgroup 
icon. 

6. Highlight Server1 or Server2; then click Add. 

7. Click Next. The Login screen displays. 

8. Enter the Administrator password (if any); then click Log On. The Analyze 
Selected Server screen displays. 
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9. Notice that the installation program has detected the antivirus software that is 
installed on the server. Click Next → Next. 

10. In the Proxy Information screen, click Next. 
11. In the Trend VCS Server Information screen, enter the IP address of the 

computer running Trend VCS (10.10.10.2 or 11.11.11.2). Click Next. 
12. In the Agent Information screen, enter a site name for the server; then click 

Install. 

13. Click OK → Next → Done. 
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Verifying Management in Trend VCS 
After the agents have been configured, you should be able to view the information 
about the server running ServerProtect in the VCS console. 

To view server information: 

1. From your client computer, run the Trend VCS console by clicking Start → 
Programs → Trend Virus Control System → Trend VCS Console. The web 
browser opens and displays the VCS console. 

2. Double-click the icon in the left pane that represents your Trend VCS 
domain. 

3. Highlight the name of the site that displays below the domain. Information 
about that site will display in the right pane. 

 
 

You can now administer the site using Trend VCS. 
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Lab Review 
1. What is a ServerProtect domain? 

............................................................................................................................  

............................................................................................................................  

2. What is an information server? 

............................................................................................................................  

............................................................................................................................  

3. What is the benefit of using Trend Micro Virus Control System? 

............................................................................................................................  

............................................................................................................................  

4. What are the two main components of Trend VCS? 

............................................................................................................................  

............................................................................................................................  
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